Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have done the following:

sudo apt-get install vim-gnome

But I get the following:

vim-gnome : Depends: libruby1.8 (>= 1.8.7.352) but 1.8.6.111-2ubuntu1 is to be installed
E: Unable to correct problems, you have held broken packages.

I've done:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade

Contents of my /etc/apt/sources.list file:

deb http://us.archive.ubuntu.com/ubuntu/ oneiric main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric main restricted
deb http://us.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric-updates main restricted
deb http://us.archive.ubuntu.com/ubuntu/ oneiric universe
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric universe
deb http://us.archive.ubuntu.com/ubuntu/ oneiric-updates universe
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric-updates universe
deb http://us.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric multiverse
deb http://us.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse
deb-src http://us.archive.ubuntu.com/ubuntu/ oneiric-updates multiverse
deb http://security.ubuntu.com/ubuntu oneiric-security main restricted
deb-src http://security.ubuntu.com/ubuntu oneiric-security main restricted
deb http://security.ubuntu.com/ubuntu oneiric-security universe
deb-src http://security.ubuntu.com/ubuntu oneiric-security universe
deb http://security.ubuntu.com/ubuntu oneiric-security multiverse
deb-src http://security.ubuntu.com/ubuntu oneiric-security multiverse

But all to no avail. I always get the same error above.

What can I do to resolve?

share|improve this question
    
I wonder why is your libruby still at 1.8.6? The ubuntu repositories contain 1.8.7 (packages.ubuntu.com/oneiric/libruby1.8). Are you using the main repository? Enter gnome-control-center software and see the „Download from” setting. –  lgarzo Nov 9 '11 at 15:50
    
It's set to download from Server for United States. –  croceldon Nov 9 '11 at 15:54
    
does running sudo dpkg --configure -a help? –  Anarci Nov 9 '11 at 15:58
    
You can try to set it to „Main server” and do an update, just to exclude the case that your repository is not up-to-date. If it does not help set it back, it eases the load on the main servers. –  lgarzo Nov 9 '11 at 16:04
    
Changing to main server didn't help. it allowed dist-upgrade to run without any errors, but I still have the same situation when trying to install vim –  croceldon Nov 9 '11 at 17:45

2 Answers 2

up vote 3 down vote accepted

You'll need to check your sources. I see that libruby1.8 1.8.7.352-2 is available through main while it seems that the newest version you have is: 1.8.6.111-2ubuntu1. This probably means that you dist-upgrade failed or that you still need to update your sources.

$ apt-cache policy libruby1.8
libruby1.8:
  Installed: 1.8.7.352-2
  Candidate: 1.8.7.352-2
  Version table:
 *** 1.8.7.352-2 0
        500 http://archive.ubuntu.com/ubuntu/ oneiric/main amd64 Packages
        100 /var/lib/dpkg/status
share|improve this answer
    
How do I update the sources? I've already tried doing the apt-get install update/upgrade... The dist-upgrade fails with the same error I posted in the original question. –  croceldon Nov 9 '11 at 15:55
    
From which distribution are you upgrading? That should help to know if there's any known problem. I've checked the libruby1.8 package version in natty and looks like you're upgrading from an older distribution. –  jcollado Nov 9 '11 at 16:51
    
I'm afraid you're getting over my head. I can't even remember what I've upgraded (I've done several upgrades on this little used installation). –  croceldon Nov 9 '11 at 17:44
    
Looking at hardy and intrepid, I'd say that you're getting a version from hardy (you could still see that using apt-cache policy libruby1.8 as I did above anyway). The recommended upgrade path would be upgrade to the next LTS and later to the next following distro: 8.04 (LTS) -> 10.04 (LTS) -> 10.10 -> 11.04 -> 11.10. Those are probably too many upgrades, so I'd advice to backup your home directory and install oneiric 11.10 from scratch. –  jcollado Nov 10 '11 at 5:20

The following worked for me:

run this

sudo apt-get update 

and then run

sudo apt-get install vim-gnome 
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.