Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After a fresh install of Ubuntu 11.10 64-bit, the boot seems to stop after selecting the ubuntu option (same with the rescue one) in the grub menu.

At first I thought this was related to grub-efi, as I've had similar problems after a Ubuntu 11.04 update which replaced grub-efi with grub-pc and got me stuck on a "elf magic" grub console (https://bugs.launchpad.net/ubuntu/+source/apt/+bug/800910).

While the 11.04 problem was resolved with a simple chroot and apt-get install from the live cd, that solution doesn't work this time.

The drive with the bootloader is a sata3 ssd with 64 gb gpt (sdb1 20 mb efi boot partition fat16, sdb2 60 gb root ext4 and sdb3 4 gb swap) on a msi e350ia-e45 mainboard with a pair of 2 TB ext4 mbr drives for photos/music/movies.

I've tried a few grub-install/update-grub with boot-directory sdb1 from chroot, but I cant seem to go anywhere.

Even this guide: http://en.gentoo-wiki.com/wiki/Grub2#EFI (ofc I replaced grub2 with grub in the grub-install and efibootmgr commands) doesnt seem to get me anywhere.

Any help or ideas are appeciated ;)

edit: I guess its the combination of gpt/uefi that also seems to haunt f16

edit: same with 12.04 beta btw

share|improve this question
    
are you able to boot from a Live CD –  Ringtail Apr 1 '12 at 17:11
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. I am flagging this for closure. Regards, –  Ringtail Apr 3 '12 at 19:18
    
also, this guy posted bout the same routine I've been trying for months now: superuser.com/questions/376470/how-to-reinstall-grub2-efi still doesnt work for me though –  Spleen Apr 27 '12 at 17:33
    
@blueXrider and yeah, live cds work fine –  Spleen Apr 27 '12 at 17:46

1 Answer 1

After another 2 days I finally have a solution.

I switched the SATA controller from AHCI to IDE in my BIOS, which made the system bootable, but I still wasn't happy with that.

So I searched around a bit and figured that the AHCI kernel module wasnt loaded at all, which explains why the live CD and IDE mode worked.

So I added the AHCI module to the initramfs:

gksudo gedit /etc/initramfs-tools/modules

In the text editor, I just added ahci at the end of the file. Then I saved the file, closed the text editor, and ran:

sudo update-initramfs -u

Now booting works fine. I guess I'll have to redo that every time there's an kernel update, though.

share|improve this answer
    
You will generally not have to redo this every time you upgrade your kernel to a newer version; this fix should be retained across kernel updates. –  Eliah Kagan Jun 27 '12 at 8:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.