Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an A3 phone from Thailand, when I connect it to my PC running Windows it prompts me to install the driver to make it work properly. However, when I use my Ubuntu 10.10 there is an error detecting the device but I'm able to charge it. Is there a way I can make it work with Ubuntu?

share|improve this question

1 Answer 1

Usually you have to enable the USB connection from the handset, too. Pull down the notification bar at the top of the screen, and switch the USB connection on. You don't need any drivers for this with Ubuntu, USB already works fine.

There's also an Android Stack Exchange site (like this one) over here.

share|improve this answer
    
Thanks for the reply Tom. If I connect my phone to the computer running Ubuntu the USB manager prompts me to select from three modes, Data Storage, Data Card and Charge Only. If I select the first option nothing happens, for the second the device appears a modem but with no apparent use. So what should I do to make it appear as a data storage (usb stick)? –  tsega Nov 10 '11 at 6:52
    
@Tsega It looks like you are using some non-standard version of Android, or have some UI overlay (Like HTC's Sense UI), that is confusing things. The problem here isn't with Ubuntu, so you have to look for the handset's documentation somewhere. Alternatively, you can forget USB and use the Remote Desktop app to move stuff to and from the phone over WiFi. Best way forward is to post your original question on the Android site in my original answer, or over on XDA-Developers. Good luck. –  Tom Brossman Nov 10 '11 at 10:21
    
thanks for the tip, I didn't consider using the wifi, I just tried it and it worked for me. I don't really need to connect using USB and I think you might be right in saying that he UI overlay is causing the problem. Thanks again for your help. I would vote for you but I don't have privileges to do that just yet. –  tsega Nov 11 '11 at 5:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.