Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently bought a Sitecom Wireless Network Access Point 300N WL-331. It's very easy to install. I tested the connection by connecting from 2 different laptops running Windows 7 (everything went fine) , then I tried it with 2 android devices (again everything went fine).

Now it was time to try using the AP from Ubuntu 11.10. (One of the laptops run on dualboot). Since I boot into Ubuntu 95% of the time, it's essential that this works.

I tried connecting, it worked perfectly. All pages load fast, I did a speed test and I get 47mbps download (my ISP provides 50mbps so that's good)

Once I added some security to the AP (WEP key) some problems came up on my Ubuntu machine:

  • When I connect the first page displays fast (google.com) but it keeps on loading
  • After that when I try loading ANY other page it takes ages... :(

If I reset the AP and leave it unprotected, everything is nice and fast. I also tried adding a WPA protection but the same problem keeps occurring.

EDIT: Wireless Card: Intel Link 5100

Anyone got an idea?

PS: After adding a protection, I tried again on the Windows machines + android devices and they run like they were running before so I'm guessing it's an Ubuntu issue.

Thanks in advance!

share|improve this question
    
plz add more information about your wireless card. –  Bruno Pereira Nov 9 '11 at 11:02
    
Wireless card information added ;) –  KennyDs Nov 9 '11 at 11:54
add comment

1 Answer

Edit the file (or create) /etc/modprobe.d/options.conf, add the line

options iwlagn 11n_disable=1

or

options iwlagn 11n_disable50=1

Try each and see which works for you.

Reboot for testing on each line you are testing

sudo reboot
share|improve this answer
    
Thanks, will try this when I get home and keep you updated. –  KennyDs Nov 9 '11 at 12:01
    
perfect ;) anything, drop a comment. –  Bruno Pereira Nov 9 '11 at 12:03
    
I just created the file as instructed and rebooted and now I don't even have the option to connect to a wireless network. Seems like my wireless has dissapeared. Any other ideas? Thx alot already :-) EDIT: I just left the "options iwlagn 11n_disable=1" in it and now it seems to be working ;). EDIT2: I just did a speedtest and I'm only getting half of my speed I should be getting. I tested it on my Windows OS and it was double the speed I have now on my Ubuntu machine. Any idea? –  KennyDs Nov 9 '11 at 20:20
    
This disables N rate speeds in your wireless card so its normal that you do not have the same speeds as using the windows drivers, I think this is reported somewhere as a network-manager problem one of the solutions removes network-manager and installs wicd instead, might work for you but can also break (believe not but you never know) your system a bit. Drop a comment if you are interested in trying this. –  Bruno Pereira Nov 9 '11 at 22:31
    
Sure I'm definitely interested in trying it out, any guidance? Already upvoted btw –  KennyDs Nov 10 '11 at 6:46
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.