Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've noticed that Compiz fails to set window rules on many (if not all) Java applications.

For example, I want to start PHPStorm on second desktop, so I add a rule to Place Windows > Windows with fixed viewport: class=PHPStorm (I actually grab the classname), but it just start on active desktop, not the one i've specified. Is there some workaround for this?

P.S. it works fine for class=Firefox and class=Gnome-terminal

share|improve this question

closed as too localized by Luis Mar 14 '13 at 16:18

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

2  
This has been inappropriately closed by Luis Alvarado. This is a valid question of valid behaviour on Ubuntu that is buggy. Compiz does not place Java windows correctly. There are plenty of Java applications running on Ubuntu who's dialog screens end up off screen or below the window line, due to this Compiz bug. P.S. I'm a future visitor and I would like to know the answer to this question. –  Damiön la Bagh Mar 18 '13 at 23:41
    
opened a bug for this issue. bugs.launchpad.net/ubuntu/+source/compizconfig-settings-manager/… –  Damiön la Bagh Mar 19 '13 at 0:08

Browse other questions tagged or ask your own question.