Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a dell inspiron computer. I installed Ubuntu 11.10. I don't want to use its touchpad but I could not disable it. gconf-editor cannot be useful because touchpad is not seen in peripherals although it is properly working.

What should I do?

My hardware: Alps Touchpad for Inspiron N5110

share|improve this question

3 Answers 3

up vote 1 down vote accepted
sudo add-apt-repository ppa:atareao/atareao
sudo apt-get update
sudo apt-get install touchpad-indicator

After installation, open the indicator from Applications -> Accessories -> Touchpad Indicator and set your touchpad in top-right

This is the easiest way to disable.

share|improve this answer
    
It's apparent that the touchpad is not detected as such by the system. What would the indicator be good for? –  mikewhatever Nov 9 '11 at 11:00
    
My touchpad is properly working. I would like to disable it. Gaurav_Java's method works fine. –  adba Nov 9 '11 at 21:10
sudo add-apt-repository ppa:atareao/atareao
sudo apt-get update
sudo apt-get install touchpad-indicator

This didn't work for me until I unplugged and plugged my mouse back in... -12.04Beta

Works great now though!

share|improve this answer

touchpad-indicator didn't work for me, so I wrote a little script to do it instead, and bound it to a shortcut key (Ctrl-F1).

it's a wee Python script, only a dozen lines, just sharing it in case anyone else finds it useful:

grab the code from: https://gist.github.com/1336648

save as /usr/local/bin/toggle_touchpad.py, eg by opening

gksudo gedit /usr/local/bin/toggle_touchpad.py

and pasting the code in.

then, sudo chmod +x /usr/local/bin/toggle_touchpad.py

then, go to settings-->keyboard-->shortcuts-->custom shortcuts add a new shortcut, call it eg toggle touchpad on/off, and give the command as toggle_touchpad.py.

Click OK, then click on the new row. Now click where it says "Disabed" in the new row, it will say it's waiting for a new shortcut key. I chose ctrl+F1

important: then log off and log back on again

voila! feedback, comment, suggestions appreciated

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.