Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Fellow Ubuntu users! I recently dual-booted Windows 7 and Ubuntu 11.10, and I am in a bit of a fix. When I want to connect to the internet with Ubuntu, Network Manager is showing that my device is not ready to use (exactlty device not ready). It works fine on Windows, however, since I'm using the same computer to type this as the one that is having the problem right now.

Here are the specs. If you need more, let me know! :)

  • Computer: HP G71 Notebook
  • Internet card: Intel(R) WiFi Link 1000 BGN
  • OS: MS Windows 7 Home Premium 64-bit, Ubuntu 11.10 64-bit.

This is the result of using the command sudo lshw -class network:

  *-network DISABLED      
       description: Wireless interface
       product: Centrino Wireless-N 1000
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlan0
       version: 00
       serial: 00:1e:64:4d:39:04
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlagn driverversion=3.0.0-12-generic firmware= build 35138 latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:44 memory:d3500000-d3501fff
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 02
       serial: 00:26:9e:7b:b0:c0
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=N/A latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:42 ioport:2000(size=256) memory:d1410000-d1410fff memory:d1400000-d140ffff memory:d1420000-d142ffff
share|improve this question
I also forgot to mention that Network Manager can tell me whether the switch for the wireless is on/off, but it does not do anything besides say "your hardware is turned off by a switch", if off, and the "device not ready" if on. I also tried rebooting. It didn't work. – Fahad Shaik Nov 9 '11 at 6:13
could you update your post with this information sudo lshw -class network – hhlp Nov 9 '11 at 18:28
Wireless also doesn't work on Kubuntu 11.10, if you are wondering about it. – Fahad Shaik Nov 12 '11 at 23:32

try to turn the wireless on with hotkey
usually Fn + F[1 - 12] (just look for button that have signal / antenna icon)
in my laptop its Fn + F3

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.