Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just got a new Dell XPS 15 L502X with these specs:

  • CPU Intel i7 2670QM with Turbo Boost (integrated graphics : Intel HD 3000)
  • Discrete Graphics: Nvidia GT 525M

It was ordered from Dell France. Before ordering it, the salesman assured me my configuration does not have Nvidia Implemented. I called back Dell Support in France and once again they told me all XPS 15 with i7 have Nvidia Optimus disabled in them even though the systems have two graphics chipsets (Intel and Nvidia).

I installed Ubuntu 11.10 but before installing Bumblebee or Ironhire I want to make sure my system has no Optimus.

The command ~$ lspci -vnnn | grep VGA

gives the following:

00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116] (rev 09) (prog-if 00 [VGA controller])
01:00.0 VGA compatible controller [0300]: nVidia Corporation Device [10de:0df5] (rev a1) (prog-if 00 [VGA controller])

How can I make sure of this. Thanks in advance.

share|improve this question
    
What does the computer manual say as to the specification? Have you browsed the BIOS settings for anything that would answer this question? Perhaps an option to enable/disable Optimus? –  grahammechanical Nov 9 '11 at 3:24
    
I browsed the BIOS (version A6) and there is aboslutely no ption to enable/disable Optimus. And the Computer manual is just for newbies (Function of buttons and basic specs). –  Hanynowsky Nov 9 '11 at 15:42

1 Answer 1

up vote 3 down vote accepted

I dont understand what the Dell Support in France told all XPS 15 with i7 have Nvidia Optimus disabled in them. All XPS ships with nvidia Optimus enabled in it. And there is no straight forward method for Switching it Off/On even in the BIOS.

But the fact is that, while using Ubuntu, only the Intel Graphics will be used and not the nvidia card.

Summing it up, Your system currently doesnt run Optimus (In Ubuntu). It only uses your Intel graphics. And if you want to use nvidia Graphics (Which you payed, but never used) install bumblebee.

There is some interesting discussion regarding Optimus in XPS. Find it here and here

share|improve this answer
    
Actually, yes. I am using the Intel Graphics which is pretty fine for the common tasks. Yet check this: nvidia.co.uk/object/product-geforce-gt-525m-uk.html the first note about optimus at the bottom of specifications. It confirms that some configuration may not have Optimus. I am going to test with bumblebee even though it is sad to know the HDMI port would still be inactive. I'd test and mark your answer validated later. Thanks. –  Hanynowsky Nov 9 '11 at 15:58
    
Ok fine, BTW here is the wiki page for the xps, some methods mentioned to turn off/on graphics card (even though I haven't tested it yet). Seems like it may be helpful in some sort for the XPS owners :) wiki.ubuntu.com/HardwareSupport/Machines/Laptops/Dell/XPS/15 –  Nikhil Nov 10 '11 at 6:45
    
Thanks Nikhil! Indeed we can switch on/off the card. But as I am using the laptop as a desktop replacement It is usually on AC power (no need to deactivate the nvidia). I still have to look forward to when bumblbee would be able to enable the HDMI port and have its own UI (which is in candidate release cycle now). (By the way Installation of bumblebee went smoothly and optirun does the job). –  Hanynowsky Nov 11 '11 at 3:33
    
The best method to use HDMI will be a mini-displayport-to-HDMI adapater (Ubuntu recognises it automatically) and bumblebee provides nvidia acceleration :) –  Nikhil Nov 11 '11 at 3:58
    
It is not that. I am already using the mini DisplayPort to DVI adaptor for an external (1920X1080p) monitor and as you said, it is natively recognized by Ubuntu and Nvidia proves accel. I am rather interested in activating the HDMI port to be able to use a second external Monitor and have an extended Desktop. –  Hanynowsky Nov 11 '11 at 21:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.