Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

With release 11.10, an old byobu setting I had from screen no longer works. I used to just add

esacpe ``

at the end of ~/.byobu/keybindings to make the tickmark by escape for byobu key sequences. That allowed me to free Ctrl-a to get the standard Readline / Bash / Emacs / ... emacs behaviour of jumping to the beginning of the line.

No more. Now byobu-ctrl-a interjects, and I have not been able to figure out to the old behaviour (in essence: all defaults, but ` as escape sequence) back.

Hints, or better still, solutions, would be greatly appreciated.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

You can set this up using byobu-config. Just type that in the command line and select "Change escape sequence" and off you go. Admittedly it only allows you to set a Ctrl- sequence.

This does appear to edit ~/.byobu/keybindings for you. I tried editing it by hand and it worked for me. The contents of mine with backtick working is:

source /usr/share/byobu/keybindings/screen-escape-keys
escape ``
register x "`"      #     | Goes with the F12 definition
register x "^A"
share|improve this answer
    
You're the man -- works here too. Many thanks! –  Dirk Eddelbuettel Nov 8 '11 at 23:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.