Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install utorrent program, and when I execute the program I get

./utserver: error while loading shared libraries: cannot open shared object file: No such file or directory

I'm navigating the different forums since yesterday and I didn't find anything helpful till now, so please tell me what's the problem ??

share|improve this question
Sorry to say but libssl0.9.8 is required by Comodo Antivirus and does not work under Ubuntu 16.04, which by the way has libssl1.0.0 installed on it. Why is it happening? – César Biosca Jul 16 at 1:40

In general you should search for software through the software center or if you like the command line, you can use apt-cache search. In this case, the following package showed up (on 11.10): libssl0.9.8

You could try to install it (sudo apt-get install libssl0.9.8). If this does not help, you might want to tell us, which ubuntu version you are using.

share|improve this answer

On Ubuntu 12.04 64bit version, it worked to install the 32 bit version:

sudo apt-get install libssl0.9.8:i386

But, of course, when you're on 32 bit Ubuntu, this should just work (without the :i386):

sudo apt-get install libssl0.9.8
share|improve this answer

If you are using 11.10 (since you did not mention it) you then have libssl1.0.0 which is higher than 0.9.8. Any program that needs 0.9.8 will also be able to handle versions above that one.

If you do NOT have 11.10 then you have several ways:

  1. Go to the OpenSSL site: and follow installations there.

  2. Go to Ubuntu Packages and download the .DEB from there:

  3. Go to Debian Packages and dowload the .DEB from there:

  4. Install it via apt-get or aptitude:

    • sudo apt-get install libssl0.9.8 - For 0.9.8 Version
    • sudo aptitude install libssl0.9.8 - For 0.9.8 Version
    • sudo apt-get install libssl1.0.0 - For 1.0.0 Version
    • sudo aptitude install libssl1.0.0 - For 1.0.0 Version
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.