Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Just installed a fresh copy of Maverick, and went from my two monitors working perfectly to broken in seconds.

As usual I configured the monitors in the display applet, this worked fine. I also hit Make Default which gave me no problems. I then restarted and the monitors had gone back to Mirror Screen. I changed them back again and hit Make Default which gave me a message about setting the Virtual Desktop resolution. After this any changes I make to the monitors give me the message "Please log out and back in again" - I've tried that and restarting but still cannot configure the monitor resolutions.

Any ideas on how I can revert this? Some searching indicates the problem's with xorg but I've no idea where to go further than this.

Here's the relevant lspci output:

01:00.0 VGA compatible controller: ATI Technologies Inc M92 [Mobility Radeon HD 4500 Series]

I tried extending the desktop using ATI's Catalyst tool but this still mirrored the screens. Does this mean the drivers aren't being used?

share|improve this question

2 Answers 2

up vote 2 down vote accepted

According to your edits:

you disabled the ATI drivers and it works automatically.

Problem solved, at least for now.

share|improve this answer

I was having issues with setting up my dual monitors as well. I had to go into my BIOS and set my default video adapter from Auto to PCI x16.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.