Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How do I enable the built-in wireless on my hp mini 110-3710?

There is no check mark next to Enable wireless. It disable wireless when you try it.

My wirelss card is greyed out (RTL8188CE) and says wireless is disabled under it.

If I plug in a USB wifi adapter it works without a problem. Definitly an issue with internal wifi card. The wifi button on the keyboard will disable all wireless if I press it. It will grey out the ENABLE WIRELESs on the network manager if pressed, and will ungrey it when pressed again. So it seems to have no effect on the actual hardware. Just on the wireless networking service.

  *-network DISABLED      
       description: Wireless interface
       product: RTL8188CE 802.11b/g/n WiFi Adapter
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: wlan0
       version: 01
       serial: d0:df:9a:93:82:be
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=rtl8192ce driverversion=3.0.0-12-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:16 ioport:3000(size=256) memory:55000000-55003fff
  *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 05
       serial: 44:1e:a1:cd:cc:d3
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8105e-1.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:43 ioport:1000(size=256) memory:52004000-52004fff memory:52000000-52003fff


0: hp-wifi: Wireless LAN
    Soft blocked: yes
    Hard blocked: no
1: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
share|improve this question
    
sudo lshw -class network:PCI (sysfs) –  Frank Barcenas Nov 8 '11 at 20:19
    
0: hp-wifi: Wireless LAN Soft blocked: yes Hard blocked: no 1: phy0: Wireless LAN Soft blocked: no Hard blocked: yes 2: phy1: Wireless LAN Soft blocked: no Hard blocked: no –  Frank Barcenas Nov 8 '11 at 20:20
    
ok, I will run them again with the usb device removed. If I don´t connect it. I have no way of getting the results to you. –  Frank Barcenas Nov 8 '11 at 20:41
    
ok added to question –  Frank Barcenas Nov 8 '11 at 20:49
    
sudo rmmod -f acer-wmi gave an error. NO SUCH FILE –  Frank Barcenas Nov 8 '11 at 21:14
show 2 more comments

closed as too localized by Bruno Pereira Feb 28 '12 at 18:12

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

up vote 0 down vote accepted

From the command line:

sudo modprobe hp-wmi
sudo service network manager restart
share|improve this answer
    
that did do anything except disable my usb wireless device again. –  Frank Barcenas Nov 8 '11 at 20:21
    
0: hp-wifi: Wireless LAN Soft blocked: yes Hard blocked: no 1: phy0: Wireless LAN Soft blocked: no Hard blocked: yes –  Frank Barcenas Nov 8 '11 at 20:48
    
OK, just did the sudo modprobe hp-wmi and restarted the network-manager daemon. Now I lost all wifi even the USB now greyed out and says "wireless is disabled by hardware switch." –  Frank Barcenas Nov 8 '11 at 21:52
    
Hmm... Does it say anywhere on your computer what wireless network adapter it uses? –  William Nov 8 '11 at 22:24
    
It shows up as an RTL8188CE using driver=rtl8192ce v3.0.0-12 which is the latest. I'm stating to think I should compile and install hp-wmi from source. Maybe there is an update that fixes this bug. –  Frank Barcenas Nov 8 '11 at 22:45
show 2 more comments

Not the answer you're looking for? Browse other questions tagged or ask your own question.