Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am unable to install software using the Software Center at work. A nearly identical install of 11.10 at home works fine. I suspect the proxy settings are the problem, as they are used at work, but not at home. The system at work does browse the web and respond appropriately to nslookup's.

share|improve this question
    
Related: askubuntu.com/questions/41688/… –  WarriorIng64 Nov 8 '11 at 19:03
add comment

2 Answers

Create or edit /etc/apt/apt.conf defining your proxy configuration_

Acquire::http::Proxy "http://username:password@proxy_name_or_ip:port/";
Acquire::https::Proxy "https://username:password@proxy_name_or_ip:port/";
Acquire::ftp::Proxy "ftp://username:password@proxy_name_or_ip:port/";

You could ignore the username and password if you make no use of they, and you could ignore https or ftp in the same way.

This is based on a comment in a ticket reporting this issue.

share|improve this answer
add comment

Search for "network proxy" in Dash. Fill out your proxy details and set it system wide. Now, the software center can get the required packages via proxy server you set.

share|improve this answer
    
In Ubuntu 11.10 the system wide proxy setting is done via the network settings. And i still have the same problem after setting the proxy. –  jgomo3 Mar 7 '12 at 15:57
add comment

protected by Community Aug 28 '12 at 19:57

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.