Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Usually when i try to reach a back button on my browser, I end up with a launcher popping over it. So instead of simply pushing "back" button I have to deal with a launcher. I think this is unity's launcher design problem. Should I file a bug or what?

share|improve this question
    
What do you mean by "I end up with a launcher popping over it"? Do you mean that when you press the back button, the launcher suddenly appears over the browser? What if the browser is on the other side of the screen? Which browser are you using? Does it happen in other browsers? –  user32085 Nov 8 '11 at 17:55
    
@vts Which browser are you using? –  Christopher Kyle Horton Nov 8 '11 at 17:57
1  
Do you mean that you're using the browser maximized, and by touching the left edge of the screen to reach for the back button, mistakenly the Unity bar slips out and the wrong button is clicked? –  lgarzo Nov 8 '11 at 17:58
1  
I think this is a design bug. I'm confirming this and observe the same annoying behaviour when trying to select a text which is in a fullscreen application on the left. –  arrange Nov 8 '11 at 18:01
1  
I found that in Unity 2D this is not an issue, due the higher reveal timeout –  giowck Nov 26 '11 at 20:16

3 Answers 3

up vote 6 down vote accepted

I had the same "problem" which I fixed by installing CCSM (CompizConfig Settings Manager) and setting in the Ubuntu Unity Plugin the option Hide Launcher to NEVER. This way when the browser opens the left side of it will be right next to the launcher and not on top or below of it so you can see both, the launcher buttons and the browser buttons.

There is no need to approach the edge slowly, not have the buttons in their typical place or not have it maximize since this are not solutions to the confusion between both elements.

After changing the option in the Unity Plugin, at least in my case I had to reboot to take effect. Just in case it happens to you. You safe with this some valuable seconds when browsing and want to check something quickly.

At the end it should look like this:

enter image description here

See how the browser's left limit is the actual launcher and not the resolution border.

share|improve this answer
2  
This workaround works, but still launcher behavior out of the box is wrong, and it needs to be fixed for new users. –  vts Nov 9 '11 at 18:15

I doubt this is a bug. To me, it sounds like you have your browser set up such that the Back button is positioned on the far left side of the window, which is maximized. To make the launcher appear, you'd have to be moving the mouse against the side of the screen with a certain amount of speed to it.

My suggestions in this case are to either:

share|improve this answer
    
"try increasing the "Edge Reveal Timeout" setting, if you're running 11.10" Worked for me –  giowck Nov 26 '11 at 20:15

Unity side bar is hidden by default in Ubuntu (all versions since 11.04). This is a feature not a bug.

The Compiz solution is just a changed setting and not a work around. Your cursor held to the very left, needs to be ever so slightly increased so that bumping it to the edge doesn't reveal it.

Auto hiding is not a bug, but a feature that can easily be adjusted to whatever your preference may be; auto-hide or always present.

share|improve this answer
    
This information is not correct. Launcher's default setup is not auto hide. –  user91091 Nov 18 '12 at 12:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.