Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Long time user of Ubuntu struggling to use Unity here....

I am running Unity 2D and can click on the workspace launcher icon to switch to a different workspace. However if I just walk up to a system, how can I tell by looking what workspace I am on?

Is the launcher icon supposed to change when you change workspace? Is there an indicator applet for this I can install? I am used to the old Gnome workspace switcher in the middle of the top panel!

share|improve this question

3 Answers 3

up vote 15 down vote accepted


This functionality is now inbuilt within 13.04 and later - the launcher workspace icon shows which workspace you are currently on:



12.10 and previous

enter image description here


To do this, first install the PPA:

sudo add-apt-repository ppa:geod/ppa-geod

Update and install:

sudo apt-get update
sudo apt-get install indicator-workspaces

12.04 onwards

The PPA author does not have a preprepared package for 12.04 and later. However, you can download the same deb-package used in 11.10 and install that.

Download the v0.6.2.2 deb package

Install the prerequisite:

sudo apt-get install python-wnck

how to start

Finally add indicator-workspaces to your startup-applications (search in Dash for this) if the installation hasn't already added this:

enter image description here

share|improve this answer
Thanks for your help on this. Ridiculous this isn't built in! –  HDave Nov 8 '11 at 19:42
nitpicking: we nowadays have 1 workspace and the 4 'parts' are viewports. askubuntu.com/questions/44102/… –  Rinzwind Mar 19 '13 at 15:41
In 12.10 with Unity the auto-start does not work, but the proggie can be started from the command line 'indicator-workspace', after which it works fine and interacts well with the workspace selector in the Launcher bar. Unfortunately it is not possible to name the workspaces. –  user143211 Mar 25 '13 at 8:23
This also fails if you have compiz cube rotate on or other special effects. –  HDave Mar 21 '14 at 14:54
Working on 14.04 (installed the deb package)! –  Gauthier Jun 12 '14 at 9:41

If you do download the latest version from http://ppa.launchpad.net/geod/ppa-geod/ubuntu/pool/main/i/indicator-workspaces/ make sure you grab the required wnck libs/bindings in synaptic or the software center. Otherwise this indicator will not work.

share|improve this answer

Ubunutu 14.10 (Based off of fossfreedom's answer, sorry I need more rep to comment)

  1. sudo apt-get install python-wnck
  2. sudo apt-get install python-appindicator
  3. wget http://ppa.launchpad.net/geod/ppa-geod/ubuntu/pool/main/i/indicator-workspaces/indicator-workspaces_0.6.2.2_all.deb
  4. sudo dpkg -i ./indicator-workspaces_0.6.2.2_all.deb
  5. indicator-workspaces & disown
  6. (Add to startup as fossfreedom mentions above)
share|improve this answer
Why is this even needed? Because of Unity2D? I am using Ubuntu 14.04 with regular Unity and the workspace indicator shows on my launcher bar with no further action required, once I've enabled workspaces (Settings->Appearance->Behavior). –  Lambart 11 hours ago

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.