Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

It's connected and configured via the wizard but Enable Mobile Broadband is unchecked by default and nothing happens when I click it.

When I click on the o2 mobile broadband connection itself it briefly (around half a second) connects (the icon changes) then disconnects and I get the notification disconnected from network. The usb modem is HUAWEI E173.

I understand there have been some issues in this regard with 11.10 and just wondered if anyone else had gotten one working?

share|improve this question
add comment

1 Answer 1

You need to change some settings in network manager (edit connections):

  • APN: m-bb.o2.co.uk
  • phone number: *99#
  • username: o2bb
  • password:password

Once you've connected, go to mobilebroadbandaccess.o2.co.uk to register. I found I was disconnected fairly soon after my initial connection, but after reconnecting (either reboot or remove and reinsert the mobile broadband dongle) it seems to work fine.

share|improve this answer
    
Is this contract or PAYG settings? –  fleamour Jun 29 '12 at 18:19
    
Thanks Tom, those settings worked for me, but I had to deselect 'Enable Mobile Broadband' for the dongle to connect properly. –  user124340 Jan 19 '13 at 0:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.