Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing 11.10 I noticed that the blanking the monitor froze my system (it was not trying to sleep) When I turned that off the the screen did not lock; also there was no option to lock the session when the last VNC session disconnected. I removed the gnome-screensaver package and installed xscreensaver. Now it locks just fine on the timeout, but I still need it to lock after the last VNC session disconnects.

share|improve this question
add comment

1 Answer 1

Try this to enable it (press alt+f2 and type it on the box or run it on a terminal)

gsettings set org.gnome.Vino lock-screen-on-disconnect true

To disable it

gsettings set org.gnome.Vino lock-screen-on-disconnect false

share|improve this answer
    
Bruno, thanks for the response. I set this key, and even checked it with gsettings list-recursively org.gnome.vino It did not work –  Mike Nov 29 '11 at 17:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.