Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As the title says, i get very low sound in ubuntu, and when i raise the volume, it sounds "cracked" In windows it works fine. I've got a Realtek ALC800 soundcard, intel ich6 controller. I have tried everything, from changing the alsamixer configuration to installing the newest alsa drivers, and changing that alsa modprobe conf thing. Any ideas?

share|improve this question
    
Please tag with the version of ubuntu you're using. –  Jorge Castro Oct 16 '10 at 14:29
    
10.04, soon changing to 10.10 –  user4175 Oct 17 '10 at 12:01

1 Answer 1

In alsa some cards are not meant to be "maxed out" in volume. I would leave the mixers around 95% or so. If it is still quiet try moving some mixers and not others. This may or may not help you.

Try turning volume down in alsa a bit so it does not crackle and turn the volume up in the pulseaudio mixer to 130% or so. This may change with the alsamixer setting as well though.

You updated alsa drivers correct? Did you use a script method or the Ubuntu Alsa Backports package? I have had good results with the package myself.

If nothing else, report this as a bug. Especially if you figure out a solution. Refer to this documentation for further help: https://wiki.ubuntu.com/DebuggingSoundProblems

Sorry I could not be of more help, good luck! I know a tiny bit about sound so I can help you look into OSS or something as well (however that road I never went far down). Perhaps if all else fails give a look into this: https://help.ubuntu.com/community/OpenSound

share|improve this answer
    
those didn't work, but thank you anyway –  user4175 Oct 16 '10 at 12:31
    
Try this out: Press alt+f2 and run (no quotes) "gksudo gedit /etc/modprobe.d/alsa-base.conf" Add a new line at the bottom that says (again no quotes) "options snd-hda-intel model=auto" Then reboot. –  NightwishFan Oct 16 '10 at 13:00
1  
Your first alinea is not 100% correct as changing the volume in PulseAudio and changing the volume in ALSA is directly connected. If there is no bug in the ALSA driver, setting the volume to 100% in PulseAudio should set the ALSA device to 0 dB (meaning: no amplification), and there should be no clipping or other artifacts. –  JanC Oct 16 '10 at 17:17
    
@NightwishFan: auto is the default. If it's doing something other than auto, it's because a quirk was necessary to make it work properly to start with. –  maco Oct 16 '10 at 18:02
    
@alex: try filing a bug ubuntu-bug -s audio –  maco Oct 16 '10 at 18:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.