Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install Ubuntu 10.10 netbook edition on my Lenovo S10-3. According to the release notes, there is a bug in the kernel that forces me to add

 intel_idle.max_cstate=0

to the kernel parameters. I did this when booting the install CD and I was able to install Ubuntu. During the installation I chose to fetch updates from the net.

Now when I try to boot the machine it just hangs. I have tried booting the machine as-is and I have tried adding the above-mentioned kernel parameters. Same experience.

So, my questions is how do I install 10.10 in this machine and how do I boot it after I've installed the OS?

share|improve this question
    
I have the same problem, When I add 'before' quiet splash 'intel_idle.max_cstat=0' parameter I can install. I've used unetbootin.sourceforge.net/#other I can Install, but when I select an OS in grub, I only get a _, and it stops loading. –  user8463 Mar 4 '11 at 11:22
add comment

5 Answers 5

I've installed 10.10 Netbook addition without any modifications on my Lenovo S10e and it works fine. I didn't do the modification you mentioned and chose not to do updates during the install.

I did my installalation from a 10.10 Netbook USB stick, and I would try it again with out any mods.

share|improve this answer
add comment

Here's what worked for me

  1. In the line (Install Ubuntu_notebook_Edition) press TAB or F6 and add AFTER quiet splash 'intel_idle. Max_cstate=0' (omit '') And press "Enter" to start to install.

  2. When you finish to Install you will reboot your System but the system won't let you show anymore after GRUB.

  3. If you Focus on "UBUNTU" (First Option) and press 'e' To edit, add after quiet splash 'intel_idle. Max_cstate=0' and 'Ctrl-X' to Start as the options-on-screen says.

  4. When you finally can log into your Ubuntu edit with 'terminal' /boot/grub/grub. Conf file and search 'quiet' Just after 'quiet splash' add as you do above 'intel_idle. Max_cstate=0' and save.

Please be careful and always make a backup for your grub.conf file. To do that run this in a terminal: sudo cp -r /boot/grub* ~/grub-backup

Reboot, then login!

share|improve this answer
add comment

I found a relevant tutorial on Ubuntu 10.10 and the Lenovo Ideapad S10-3. It might be worth following the steps listed.

share|improve this answer
add comment

You will need to do the same (add the extra command) on the next boot. To do this, press ESC to bring the operating system menu (grub) just after BIOS, and edit the grub menu entry by pressing e. You would want to edit the first entry, which should be the usual Ubuntu operating system. Attach the extra parameter and it should boot fine.

In terms of making this permanent, grub menu list needs to be edited but it looks more complicated to do in the new version. In the process of looking into that now.

Cheers,

Fatih

-- To continue above... try:

sudo nano /etc/default/grub

change the following line :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=0"

sudo update-grub

share|improve this answer
add comment

In response to the person asking WHERE to enter this boot parm once they have hit the F6 Options pop-up:

Once you have the F6 option box up, hit ESC. You can them use the backspace key to remove the extra "---" chars at the end of the boot line displayed at the bottom of the screen. After you get your cursor to 1 blank space after the existing line type in the "intel_idle.max_cstate=0" (w/o the quotes) and hit enter. It should proceed to the normal booted up "try" running the OS off of the USB stick or CD.

I'm using an extremely slow USB stick (A-Data 4GB) so it may appear to die but give it a minute or two and it should come around.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.