Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have quite an extensive project planned with planner but switched my desktop to kubuntu to get away from the unity desktop of ubuntu.

Issuing the command sudo apt-get -s install planner gives the following output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following NEW packages will be installed:
  planner
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Inst planner (0.14.5-0ubuntu1 Ubuntu:11.10/oneiric [i386])
Conf planner (0.14.5-0ubuntu1 Ubuntu:11.10/oneiric [i386])

I have the following questions:

  • Is there a way to make planner work in kubuntu? or
  • is there an alternative project planing software in kubuntu?
  • What is the reason, why it does not run?
share|improve this question

1 Answer 1

up vote 1 down vote accepted

You could mix the GTK (Gnome) and the Qt (KDE) based applications. With the KDE/Kubuntu desktop the Gnome applications will install the needed GTK libraries.

Here with the Kubuntu 11.10 (simulation):

:~$ sudo apt-get -s install planner

Reading package lists... Done

Building dependency tree

Reading state information... Done

The following extra packages will be installed:

gconf2 gconf2-common libart-2.0-2 libgconf2-4 libglade2-0 libgnomecanvas2-0 libgnomecanvas2-common libgtk-3-0 libgtk-3-bin
libgtk-3-common librarian0 rarian-compat scrollkeeper

Suggested packages:

gconf-defaults-service librsvg2-common gvfs

The following NEW packages will be installed:

gconf2 gconf2-common libart-2.0-2 libgconf2-4 libglade2-0 libgnomecanvas2-0 libgnomecanvas2-common libgtk-3-0 libgtk-3-bin libgtk-3-common librarian0 planner rarian-compat scrollkeeper

--- EDIT ----

Well - that was a simulation ; )

man apt-get

s, --simulate, --just-print, --dry-run, --recon, --no-act
     No action; perform a simulation of events that would occur but do not actually 
     change the system.

Example

Installing with the command

sudo apt-get install planner

Trying to start the Planner

K > Applications > Office > Project Management

There seems to be problems. Starting from the konsole the planner is giving an error message:

The program 'planner' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAccess (attempt to access private resource denied)'.
  (Details: serial 764 error_code 10 request_code 152 minor_code 1)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Try#1

Turning the Desktop effects off (Alt+Shift+F12). System Settings > Desktop Effects.

A bit better. The Planner is starting but the planner window is blank.

Try#2

Turning the Desktop effects on and turning the GTK widget style to the Raleigh. System Settings > Application Appearance > GTK+ Appearance.

Now the Planner is starting and the planner window is readable.

enter image description here

--- EDIT #2----

The KDE project planner app is the KPlato: http://www.kde.org/applications/office/kplato/. I can't say what it's status is (good/bad). Package is kplato.

share|improve this answer
    
Doing sudo apt-get -s install planner does not install the extra packages on my machine (see edit of question...) –  Woltan Nov 8 '11 at 14:16
    
Try#2 did the trick. I really appreciate you answer! Only remaining open question is then "What is the reason, why it does not run?". –  Woltan Nov 9 '11 at 7:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.