Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Normally I like it when a terminal window pops up immediately after startup, since I'm a heavy CLI user in linux. However, my preference is to have the terminal maximized, particularly on my laptop, and the standard xfce4 startup execution leaves the terminal window to standard size.

I've tried the following:

  • Checked the .desktop files in both /usr/share/applications & /.local/share/applications
  • Checked xinitrc in /ect/xdg/ for terminal startup. A change here resolved an issue with both xfce & gnome screensavers running simultaneously, but did nothing for the terminal issue.
  • Checked Application Autostart in xfce4-session-settings, but there's no default terminal entry. When I add one, two terminal windows pop up on startup.

According to several guides I've found, editing the xinitrc file is key to the startup. However, I found no explicit terminal execution calls in that file.

What is needed to modify the default terminal startup settings?

EDIT

After further investigation, it turns out it was a setting in GNOME that set the process off. I switch between GNOME, KDE and xfce for desktop environments, and the terminal popup was based on the GNOME startup settings. When that was modified, the terminal now shows up full-sized with no problems.

share|improve this question

1 Answer 1

go to Configuration/Systemsettings/Session and Startup (i'm not sure about the exact names since my comp is in Spanish but you shouldn't have much trouble finding it) and add a new startup app with "name" - put here the name you want, it's not important

command = xfce4-terminal --fullscreen

and you're done. Also maybe check out Tilda and Guake for drop-down terminal emulators if you really are a fan of cli.

share|improve this answer
    
Thanks for the suggestion. Turns out its a gnome-terminal instance that is running on startup, not xfce4-terminal. When I tried your suggestion, a second terminal window opened up and ps -A | grep term showed both gnome-terminal and xfce4-terminal running simultaneously. –  Jason Nov 8 '11 at 21:19
    
+1 for the suggestion, but can't mark this as an answer because it didn't resolve the problem. Appreciate the help though! –  Jason Nov 8 '11 at 21:44
1  
English is : Settings / Settings Manager / Sessions and startup –  Anton Jun 26 '12 at 16:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.