Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have much trouble with Ubuntu 11.10. I have a quite new system with an ASUS M5A97, and neither NIC nor USB 2.0 are working. The first problem could be solved by using a vendor driver, but the latter still exists. Mouse (Logitech MX900) and keyboard (Logitech Illuminated KB) are not recognized. I have older devices with I have kept for emergencies plugged to USB 3.0 or PS/2 which are then regognized and working.

This chipset problem almost only exists in Ubuntu, live CDs based on other distrubutions (System Rescue CD, Parted Magic) work just fine. There is a guy reporting to have the same problem with Archlinux, but it hasn't been solved to date:

https://bbs.archlinux.org/viewtopic.php?id=125735

Is there any chance that this issue (the board is out for sale since january) will be solved one day? Has anyone an idea what to do to get the onboard USB running? Apart from switching to another distribution, of course.

share|improve this question
    
The only way to have it solved is to file a bug (bugs.launchpad.net/ubuntu). –  Javier Rivera Nov 8 '11 at 12:25
add comment

2 Answers

A firmware update to 0810 Beta (2011/10/11) via EZ Flash seems to solve the problem. The keyboard is running, the mouse still not, but this seems to be a bluetooth issue:

Keyboard/Mouse not recognised during installation

Thanks so far.

share|improve this answer
    
tried the bios update, didn't work. –  marinara Mar 14 '12 at 8:46
add comment

you'll need to download the 8068 driver and use these instructions to install it.

http://www.twm-kd.com/linux/realtek-rtl81688111e-and-ubuntu-linux/

the bad news, is that this doesn't seem to work on 3.2 kernels.

but my network is working now, since i'm running oneric. (bios update did nothing for me)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.