Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an annoying problem with Ubuntu 11.10, my mouse pointer disappears on the Ubuntu surface ( not in programs like firefox, libre office ..)

The mouse pointer is there, but its size is only one pixel and in the white background of e.g. "system" it is not seen at all, although with "ctrl" I can see where it should be. I have not found any place where I can change the size or colors of the mouse pointer. Can anybody help me?

share|improve this question

Try to use one of alternative cursor schemes. Start command:

sudo update-alternatives --config x-cursor-theme

and select the number corresponding to one of the other alternative cursor color schemes.

You should log out and log in again for the change to take effect.

share|improve this answer

Found this answer and it worked for me.

I had this problem on a Dell Optiplex 955. It has something to do with the video drivers and the default cursor set. You can set SWCursor on in your xorg configuration as discussed in this Ubuntu Forums post, however that has some performance impact (probably negligible on modern systems though).

What I did is edit /usr/share/icons/default/index.theme and changed DMZ-White to whiteglass (you can change it to any of the non-DMZ themes in /usr/share/icons with a cursor directory in its subdirectory like whiteglass or redglass)

After doing that, log out and back in to restart the X server.

share|improve this answer

You could try to change your mouse cursor theme, to see if your current theme causes the problems.

You can use Gnome Tweak Tool to change the Cursor theme settings.

To install use Software Center or sudo apt-get install gnome-tweak-tool. The cursor theme settings are on Theme page -> Cursor theme.

Alternatively Dconf Editor can change the size of the mouse cursor:

Install dconf-tools with Software Center or sudo apt-get install dconf-tools.

The cursor size can be changed on: org -> gnome -> interface -> cursor-size.

share|improve this answer

protected by RolandiXor Nov 3 '12 at 4:52

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.