Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Installed Ubuntu Oneiric Ocelot 11.1 a few weeks ago without issue on my AMD dual-core desktop machine (home-built) with AMD/ATI Radeon XFX "HD 4350" graphics card. Recently I was trying to update GRUB 2 to detect my Windows 7 installation on the machine, and followed instructions on this page -- which resulted in GRUB failing to load upon restart (I got the "grub rescue" prompt).

In trying to recover from my new problem, I followed some instructions on this page -- mainly this bit:

sudo -i
mount /dev/sda7 /mnt
mount /dev/sda6 /mnt/boot  #skip this one if not have a separate /boot partition
grub-install --root-directory=/mnt/ /dev/sda

which has now resulted in my main problem:


MAIN PROBLEM:

Now my computer will boot to GRUB, but if I let it load Oneiric the screen will go blank immediately afterward and stay blank after reboot -- also, the monitor will turn off and claim "no signal". This can only be remedied if I boot to the LiveCD and then turn my monitor off and on again*.


My extremely ignorant opinion is that this is some kind of graphics card detection problem, but I don't know how I caused it or how to fix it. Thoughts?

I have also recently been trying to troubleshoot (i.e. googleshoot) some problems related to graphics in Gnome 3 -- I don't have specifics unfortunately, and no step I took resulted in bad behavior immediately afterward, but I suppose I might have screwed something up.

*At first I thought the recovery process was more complex but have since simplified it.

share|improve this question

4 Answers 4

This method can use only with remote (ssh) connection.

sudo vi /etc/default/grub
  1. Add this:

    GRUB_CMDLINE_LINUX_DEFAULT="vga=792"
    

    GRUB VGA Modes you can see here.

  2. Turn this on or add if you dont have it:

    GRUB_TERMINAL=console
    
share|improve this answer
    
Thanks, this fixed the issue I had with a Debian Box in a Parallels VM. –  schmunk Oct 25 '13 at 14:09

May be u use this at grub menu

At install screen press F6 and select nomodeset and install Ubuntu as usual.

  • On first boot after install, press e on getting the GRUB bootloader.
  • Using arrow keys navigate to and delete quiet and splash and type the word nomodeset in their place
  • Press Ctrl and X to boot
  • You should now be able to login to your Ubuntu as usual

Or u can try

Try Ubuntu without any changes selected, and then press F6

Add this to the end of the command line:

i915.modeset=0 xforcevesa

Then press enter and it should boot successfully.

share|improve this answer
    
Gaurav, thanks for the suggestions. I tried the first one and got a little further into the Ubuntu load process but not much. The load hung up with the GRUB background image still displaying and with this text printed out: mountall: Disconnected from Plymouth *starting Bluetooth [OK] PulseAudio configured for per-user sessions saned disabled: edit /etc/default/saned *checking battery state [OK] –  radiosig Nov 10 '11 at 2:53
    
For the second suggestion, I'm not sure I understand how to implement it; I cannot load Ubuntu "without any changes selected" at all so I'm unsure as to where to insert the string you've provided. –  radiosig Nov 10 '11 at 2:57

You need probably to repair your boot section - grub. There is a small program in Ubuntu for doing this. Here you will find all what you need: https://help.ubuntu.com/community/Boot-Repair

share|improve this answer
    
Hi Julien, thanks for you answer. I created a Boot Repair CD on another machine and ran it as per your linked instructions. It had the positive effect of adding a line in my GRUB for my Windows 7 installation, which was the original goal--sweet. However the problem I see after choosing the Ubuntu option from my GRUB menu is just the same as before: a blank screen, and then my monitor shuts off. On closer examination it seems like my computer is just idling--no boot light. Here is the link generated for my by the Boot Repair utility: paste.debian.net/144353 –  radiosig Nov 10 '11 at 2:23
    
if I understand it good: you become a grub menu, and you can choose for booting Ubuntu.And then: nothing more. OK, on the boot menu where you can choose, select ubuntu but press e (you can see the instructions on your screen), and go with the arrows to the line where you see something like "splash vga=789". Navigate afterwards this text ans just type "quiet splash nomodeset". And then press F10. If the computer is booting we are on the good way to resolve the problem. Let know. –  Julien Chau Nov 10 '11 at 12:14
up vote 0 down vote accepted

I ultimately reinstalled Oneiric and that did the trick; a little disappointing,seeing as that was my seventh or so reinstall in three weeks, but I did come out ahead in the end because the Boot Repair suggestion got me a Windows 7 line in my GRUB menu. Thanks everyone!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.