Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 11.10 on both of my PC's.

I wanted to access PC2's shared directory from PC1. So in PC2, from nautilus file manager, right-clicked on the directory that I want to share with the other PC, and clicked on "Sharing ..".

It asked me to install Samba - which I did. Then I was asked to restart - which I did. I had to do the same steps for the other PC also - which I did.

But after that when I clicked on "Browse Network", it showed "Windows Network". Double-clicking on it shows "Failed to retrieve share list from server".

Later I installed GSamba and simply went with the default settings. I did this for both systems. But still I can't access the other system from Network.

May be I am missing some steps here. Need your help please to solve this.

Thanks in advance.

share|improve this question
add comment

1 Answer 1

up vote 8 down vote accepted

I am not a Samba user, but maybe this will help you.

I use ssh to share between my multiple PCs. Open a terminal session and enter the following:

sudo apt-get install openssh-server

Once installed I then use

Nautilus ---> File ---> Connect to Server

Type the IP address of whatever PC you are trying to connect to > Change the Type to SSH > enter the rest of your credentials for that machine.

In addition to this you could explore using your Ubuntu One folder for this. This way your files will be kept up to date on both machines plus have access remotely.

Good luck

share|improve this answer
    
Thanks for your help. I just tried it. It is showing "Connecting .." for a long time and then showing a message like "... ssh unexpectedly exited ..". I am trying to connect to the folder which I shared with the Nautilus -> Sharing option. Can I access any folder of the destination PC with this SSH? Actually have no idea using SSH, so thought to ask you. About Ubuntu One, that is not an option since I have to copy a lot of data. –  Arindom Nov 8 '11 at 7:12
    
It is working now!! It was my mistake. I had to check the firewall settings first. Anyway I can access now. It's so easy. Thanks friend for your help. I really appreciate this. –  Arindom Nov 8 '11 at 7:18
    
The caveat here is that SSH is an encrypted protocol, if you are streaming something like video over the network it will be slower and use more bandwidth. This might not matter to some setups. –  Phil Hannent Nov 8 '11 at 14:08
    
Can you be a bit more specific about what "check the firewall settings" means? –  SpashHit Nov 24 '11 at 16:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.