Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

apache ask for passphrase redirects to plymouth even when I'm remoted in using SSH and away from console.

How can I disabled plymouth?

Update: I did learn that I can sudo plymouth --quit and that will shutdown plymouth. I would like to know the recommended way to disable plymouth on boot.

share|improve this question
    
Possible duplicate: askubuntu.com/questions/5065/… –  WarriorIng64 Nov 15 '11 at 8:57
    
Just disabling the splash screen isn't enough. As long as plymouth is running it will respond to the plymouth --ping that apachectl uses. –  Jay _silly_evarlast_ Wren Nov 15 '11 at 16:10
add comment

2 Answers

The How can I disable the purple splash screen at boot? has been mentioned.

You could also edit the plymouth /1/ upstart /2/ config files and prevent the plymouth start-up. I think that the /etc/init/plymouth.conf will do the trick.

Links:

  1. https://wiki.ubuntu.com/Plymouth
  2. http://upstart.ubuntu.com/
share|improve this answer
    
Just disabling the splash screen isn't enough. As long as plymouth is running it will respond to the plymouth --ping that apachectl uses. –  Jay _silly_evarlast_ Wren Nov 15 '11 at 16:09
add comment

plymouth should be stopping on its own when the boot is finished.. on a GUI that is when kdm/xdm/gdm/lxdm start. On servers, that is when runlevel 2 is finished (ls /etc/rc2.d). If it is not stopped, this is likely a bug in the bootup, and should be reported with

apport-bug plymouth

Additional Resources:

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.