Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to make my laptop as wi-fi hotspot. To do so, I pressed button Settings->Network->Wireless->Use as Hotspot..

Then it creates a wireless network connection 'Hostspot' and connects. But it gets disconnected just after making connection.

Here is my network hardware info:

sudo lshw -C network
  *-network               
   description: Wireless interface
   product: WiFi Link 5100
   vendor: Intel Corporation
   physical id: 0
   bus info: pci@0000:04:00.0
   logical name: wlan0
   version: 00
   serial: 
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
   configuration: broadcast=yes driver=iwlagn driverversion=3.0.0-12-generic firmware=8.83.5.1 build 33692 latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
   resources: irq:47 memory:d9200000-d9201fff
  *-network
   description: Ethernet interface
   product: RTL8111/8168B PCI Express Gigabit Ethernet controller
   vendor: Realtek Semiconductor Co., Ltd.
   physical id: 0
   bus info: pci@0000:05:00.0
   logical name: eth0
   version: 02
   serial: 
   size: 100Mbit/s
   capacity: 1Gbit/s
   width: 64 bits
   clock: 33MHz
   capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
   configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=N/A ip=192.168.1.4 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
   resources: irq:45 ioport:2000(size=256) memory:d5010000-d5010fff memory:d5000000-d500ffff memory:d5020000-d502ffff

My machine is running on Ubuntu 11.10

Can anybody help in it?

Thanks

share|improve this question
3  
same problem here! –  Hamed Momeni Nov 18 '11 at 7:51
    
What is the output from iwconfig , before and after you try activate hotspot? –  david6 Nov 22 '11 at 22:40
    
For Ubuntu (and certainly for 11.10), you will need to change any currently used WiFi connection to NOT 'Connect Automatically'; and then re-start the laptop. –  david6 Nov 22 '11 at 23:09
add comment

4 Answers 4

I had the same issue. I have found a report that has already been registered. There is a suggested workaround that works for me:

  1. go to System settings > Network > Wireless > Use as hotspot > Configure (or 'Edit connections' under your connections > Edit the hotspot connection)
  2. Switch to IPv6 Settings tab > Set Method to 'Ignore' and confirm/save
  3. in terminal (Ctrl + Alt + T) run the following command to kill all dnsmasq processes: sudo killall dnsmasq

  4. go to System settings > Network > Wireless > Use as hotspot

Should work, and I have set my hotspot up as it is in the Mosture's post

Link to bug report: https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/857294

Edit: I needed to set up android accessible hotspot recently, and I was successful in creating such through ap-hotspot.

share|improve this answer
    
thanks, it worked for me too. –  Hamed Momeni Nov 24 '11 at 15:21
    
thanks it worked for me too! –  giowck Dec 10 '11 at 14:45
    
This works for me too, but I cannot see the network on my Android phone. What's up with that? –  mydoghasworms Mar 2 '12 at 5:49
    
Me too cannot see the network in my Android phone. –  Junaid Mar 14 '12 at 9:58
    
I had the same issue with connecting my android phone, but I did not research it too much since the former has resolved most of my own problem. The closest you could get to solving this one could be this related question and its answer on access points: askubuntu.com/questions/68310/… –  nol Mar 19 '12 at 19:36
add comment

I have run into the same issue. The solution was that my Centrino Ultimate-N 6300 network adapter simply did not support AP mode.

Quote from the MasterMode documentation.

"'iw list' shows all supported features of all installed wireless card supporting the new nl80211 interface.

iw list

If there is 'AP' in the list of "Supported interface modes" your device will support the Access Point mode with hostapd."

In my case that support was missing. :-(

Supported interface modes:
     * IBSS
     * managed
     * monitor
share|improve this answer
    
I got this: Supported interface modes: * IBSS * managed * AP * AP/VLAN * monitor. So it is supported. –  Junaid Mar 14 '12 at 9:55
add comment

This tutorial might help you try this http://freshtutorial.com/create-your-own-wifi-hotspot-in-ubuntu-11-10/

share|improve this answer
    
Could you please include some explanation rather than just a link? This will make your answer more accessible and it will protect against the link dying. –  N.N. Nov 8 '11 at 15:09
    
This is what I did already. My problem is: Once I create a connection and connect it gets disconnected automatically. –  Junaid Nov 9 '11 at 6:47
    
This tutorial should strongly advise against using WEP as a security feasture. Only WPA2 (PSK or EAP) will provide ANY level of WiFi security. –  david6 Nov 22 '11 at 23:17
add comment

Try the following: Go to the networking menu in the upper right hand corner of the screen. Click create new wireless network. Enter details and click Ok. Post if it works or not along with any error mesages.

share|improve this answer
    
When he mentioned "Use as Hotspot" I think it was the hint that suggested he was using Gnome-Shell instead of Unity. Change the tags to reflect that since there is no Hotspot mentioned while sharing in Unity. –  Luis Alvarado Nov 8 '11 at 3:47
    
OK, I could create a network connection as you mentioned and it connects successfully, but I cant see it in the list of available Wi-Fi networks on my mobile phone. I tried with no security and others like WEP and WPA there :( @LuisAlvarado Yes I am on classic gnome 2D. –  Junaid Nov 8 '11 at 9:02
    
Hmm.. try connecting to the network on another compter, it could be a problem on your phone. Even if it does't work, it's still good diagnostic information. –  William Nov 8 '11 at 13:44
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.