Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have 2 icon do the same think (switch keyboard layout) in Ubuntu 11.10/GnomeShell. I think it is because I whitelist whole systray-area. Icon in systray (num. 1 on picture) consume much space and I like remove it. It is posible? screenshot:

enter image description here

share|improve this question

1 Answer 1

bug on launchpad

Michael Milligan (milli) instructions how to apply the patch for gnome-settings-daemon

apt-get source gnome-settings-daemon
sudo apt-get build-dep gnome-settings-daemon
sudo apt-get install devscripts build-essential fakeroot patch    patchutils
cd gnome-settings-daemon-3.2.1
wget https://bugs.launchpad.net/ubuntu/+source/gnome-settings-daemon/+bug/805747/+attachment/2544403/+files/0001-change.patch
patch -p1 < 0001-change.patch
debuild -uc -us -b
cd ..
sudo dpkg -i gnome-settings-daemon_3.2.1-*
sudo killall gnome-settings-daemon

gsd-keyboard-kbd applet should be GONE.

share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  RolandiXor Nov 14 '11 at 14:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.