Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

lshw -C network shows

  *-network
       description: Wireless interface
       product: AR5001 Wireless Network Adapter
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlan0
       version: 01
       serial: 00:1f:3a:01:c7:6a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=ath5k driverversion=2.6.35-22-server firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bg
       resources: irq:19 memory:f6000000-f600ffff
share|improve this question
    
Please outline the steps you follow to connect. –  evgeny Oct 16 '10 at 7:00
    
@Evgeny, thanks for offering but I found by manually setting the MTU, I could get it to work! :D –  Axeman Oct 16 '10 at 7:32
    
can you accept your own answer so it stops being listed as "unanswered"? thanks –  maco Oct 16 '10 at 16:12

1 Answer 1

up vote 1 down vote accepted

I solved this 20 minutes later. I had done a lot to try to get networking working. I was just about to delete a line in /etc/modprobe.d/blacklist-ath_pci.conf when I decided to give nm-applet one last shot and after filling out the SSID and other information for my network for the two-dozenth time, I just decided to manually set the MTU value.

After applying, I finally got the coveted ¨Connect¨ dialog! I had been reading about this mythical beast all evening.

So if anybody looks in here, sometimes with an Atheros 5K, you have to manually set the MTU.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.