Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I use this command:

gst-launch ximagesrc ! video/x-raw-rgb,framerate=5/1 ! ffmpegcolorspace ! theoraenc !        oggmux ! filesink location=desktop.ogg

ximagesrc usage

It shows me only desktop screenshot and video length is 0:00 or sometimes it just shows pictures without mouse motion.

More information: Ubuntu 10.04.3 this is a text

share|improve this question

1 Answer 1

You can try something like this:

gst-launch ximagesrc use-damage=0 ! video/x-raw-rgb,framerate=15/1 ! ffmpegcolorspace ! x264enc ! matroskamux ! filesink location="test.mkv"

Perhaps just the use-damage=0 parameter to ximagesrc will help.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.