Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem get the WiFi to work in Ubuntu 11.10.
When I use gnome network manager it indicates that wireless is disabled by hardware switch while it is not.

In the Network Settings Panel in the wireless section, it only shows the hardware address and the switch is off and it's disabled so that I can't change the status to On.
At the bottom there is an airplane mode switch which is On, and turning it off has no effect and it immediately turns back on.
I use a Dell Vostro 1520 laptop.

share|improve this question

4 Answers 4

up vote 1 down vote accepted

get the bios update from dell and you will be able to enable wireless in network manager.

share|improve this answer
    
thanks. that solved the problem. –  Hamed Momeni Nov 9 '11 at 9:09

Try the following in a terminal:

sudo rfkill unblock all
sudo ifconfig wlan0 up

If your laptop has a hardware wifi switch, try that. Try various combinations of these.

share|improve this answer
    
The actual hardware switch is on as I said and none of the commands above helped. thanks anyway. –  Hamed Momeni Nov 7 '11 at 17:00

I had the same problem in Debian "testing" with Gnome 3. I could not turn off the airplane mode. I have a button on my laptop which allows me to enable/disable the wireless card (Fn+F11). Hitting this button had no effect in Debian.

I have dual-boot with Ubuntu, so I booted into Ubuntu 10.10 and there the wireless was disabled as well. But, hitting the same wireless button on my laptop enabled the wireless card again. And when I booted back in Debian, wireless was working fine again.

share|improve this answer
    
I just started hitting fn with random fnumbers and it started working again. I think it was fn+f8 that did it. –  Spencer Cooley Apr 9 '12 at 20:08

I had this problem on my Dell Inspiron 6400. Fn + F2 sorted it. There is actually a picture of a wireless mast on the F2 key.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.