Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I upgraded to 11.10 and lost power during the upgrade. After bringing the box back up, I attempted to continue the upgrade and at one point did a partial upgrade to resolved dependency issues that I thought at the time were related to may failed upgrade. Now I have a working system for the most part. The problem is I can not install the 'acroread' package anymore because of dependency errors:

~ $ sudo apt-get install acroread
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 acroread : Depends: nspluginwrapper but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

~ $ sudo apt-get install nspluginwrapper

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nspluginwrapper : Depends: nspluginviewer (= 1.4.4-0ubuntu3)
E: Unable to correct problems, you have held broken packages.

 ~ $ sudo apt-get install nspluginviewer

R

eading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 nspluginviewer:i386 : Depends: libgtk2.0-0:i386 (>= 2.8.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I am running 64-bit but it seems acroread needs some 32-bit libraries that are not able to be installed. In my reading, I've found that there were some changes to multi-arch packages.

Does anyone know how I can repair my system to get around this problem?

share|improve this question
    
OP reinstalled his system –  Braiam Jun 21 at 15:22
add comment

5 Answers 5

up vote 4 down vote accepted

Try sudo apt-get install -f. It will probably give some suggestions about removing and installing packages, do what seems reasonable. If that doesn't help, try booting into recovery mode and choosing the "fix broken packages". If that doesn't work... I don't know, I'd reinstall Ubuntu if I were you. (This is a good reason to always have /home on a separate partition!)

share|improve this answer
1  
that command seems to think everything is fine. I'm researching how to move my home dir to another partition now, thanks. –  Matt Hulse Nov 7 '11 at 21:31
    
I migrated my home directory to a separate partition and reinstalled 11.10. Now I'm golden, and it really wasn't as bad as I expected. –  Matt Hulse Nov 11 '11 at 21:30
add comment

The latest release added multiple architecture support. 32 bit libraries are added as 32 bit libraries. I suspect you need to install the ia32-libs-multiarch. Try these commands:

sudo apt-get install ia32-libs-multiarch:i386
sudo apt-get check

Caught me by surprize. Also I found aptitude hasn't been updated to support the change.

share|improve this answer
    
The following packages have unmet dependencies: ia32-libs-multiarch:i386 : Depends: libcups2:i386 but it is not going to be installed Depends: libcupsimage2:i386 but it is not going to be installed Depends: libcurl3:i386 but it is not going to be installed E: Unable to correct problems, you have held broken packages. Looks like my system is hosed. –  Matt Hulse Nov 7 '11 at 21:30
add comment

You need to enable multiarch before attempting to install 32 bit libs:

 echo foreign-architecture i386 | sudo tee /etc/dpkg/dpkg.cfg.d/multiarch

After doing so, you should then be able to install whatever 32 bit libs you need.

share|improve this answer
    
Thanks for the response. I ran that command and it didn't change anything for me. –  Matt Hulse Nov 9 '11 at 15:28
add comment

Digging this up since I found this topic while looking for the same answer. The following fixed it for me, and seemed to be the result of manually installing a newer version of CUPS (trying to get airprint to work -- no luck there either -- which removed acroread) :

  • if you have not already done it, install Synaptic from the Software Center
  • Next search for libcups2
  • Package -> 'force version' to the correct one (in my case 1.5.3-0ubuntu8 from precise-updates)
  • Finally, install acroread and rejoice.
share|improve this answer
    
The problem may possibly come back later unless you also Lock Version of libcups2 in Synaptic after you did the Force Version of libcups2 in Synaptic. –  karel Aug 13 '13 at 13:16
    
Good point, though I had some hopes that the issue was a uer-caused one that wouldn't be affected by an official in-line version update (rather I broke it myself, it shouldn't break on its own). Since I can't add comments to the answer below yet... @matt-hulse I too tried the multiarch solution with high hopes and it did nothing. Any luck with the method in my answer? –  Jonathan Carroll Aug 15 '13 at 11:52
add comment

Just simply replace the "apt-get" part of your command with "aptitude" and follow the instructions and then you will must probably be okay.

share|improve this answer
3  
@Metyi Why would this work? –  Eliah Kagan Sep 2 '13 at 19:51
    
Personal experience. I was looking around to find a solution for the same problem I had. Just out of curiosity I did what I have wrote here and it solved the problem spectacularly. Not even it solved the dependencies problem it even downgraded some packages to match the prerequisites of the package I was going to install. Aptitude command is not going to give up on your request easily and tries to solve the problem more responsibly. Just give it a shot and you'll find out –  Meyti Sep 4 '13 at 18:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.