Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a partition /data which supposed to store data and its format is ext4. Since it not in home folder and I forget to format it as FAT at the beginning, I cannot copy any file into here unless I use root access. Eventually I decide to umount it.

After that, I always get the prompt /data is not mounted. Press S to skip, or press M to manually recover at booting screen. It is a bit annoying to me. If I manually recover by mount command, I can see /data visible but for just only that time. The next time the message appear again.

Anyone give me some suggestions?

Thanks.

BTW, how could I change the partition format from ext4 to FAT? I am using Ubuntu 10.04.

share|improve this question
    
Please post up your /etc/fstab, it will make things easier to diagnose. –  evgeny Oct 16 '10 at 2:27

1 Answer 1

up vote 0 down vote accepted

Try running fsck -n /data (after it is mounted), and note if there are any errors present. If you want to fix them, re-run it without the -n flag.

To format it to FAT32, you will have to copy your files from /data elsewhere, something like ~/data is a good idea (~ is the home directory, make sure there is enough space). Then fire up the Disk Utility (located under System->Administration menu), select the /data partition and format it as FAT32.

Alternatively, if you want to keep ext4, and make it user-writeable, you can run sudo chown USERNAME:users /data -R.

share|improve this answer
    
As fsck.ext4 man page says, it is not advisable to check a mounted filesystem, even when -n option is used. –  enzotib Oct 16 '10 at 2:49
    
Great thanks. I mount it into /media/data. I can use it as FAT format from now on –  aladine Oct 16 '10 at 2:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.