Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I disabled the Alt + F2 default shortcut in unity (ubuntu 11.10) using ccsm and I set a new shortcut using the default system shortcut manager (system settings > keyboard). And it works, until I execute a command like compiz --replace. After that, all shortcuts keep working normally, except for Alt + F2. It does nothing.

Any suggetions to keep the custom Alt + F2 shortcut working after compiz --replace?

share|improve this question

3 Answers 3

Install gconf-editor if you don't have it. sudo apt-get install gconf-editor
Under Apps-compiz-1-plugins-unityshell-screen0-options set execute command to whatever you want it remapped to be.

One example could be Alt. If you want to set it to something that is already occupied(in the case of this example Alt, you may need to unset that shortcut in keyboard shortcuts first).

Reports indicate that setting it to nothing is ineffective. I would recommend setting it to something you don't anticipate using.

enter image description here

share|improve this answer
Can I change key combination somehow? Because I need to press 3 buttons (alt+Fn+F2) to make it work, but that is exactly what I wanted, thanks. – mrSuperEvening Apr 27 '12 at 13:51
@hey This might be a silly question but is it possible you are confusing the HUD with the Dash? (apologises if I am way off here) – theDefector Apr 27 '12 at 13:58
@StephenMyall: Probably yes. :) I don't see how HUD is good yet, but what aking suggested is a thing I wanted. – mrSuperEvening Apr 27 '12 at 14:00
You may have better luck the changing the wording of the question from Hud to dash. this way you might be able to achieve your objective. The HUD is new to most and once you become familiar you will begin to understand its value. – theDefector Apr 27 '12 at 14:07

I would think this may be because of the order in which 'plugins' are loading. I would ensure that the setting has been changed in Unity. CCSM may be making the change under metacity.

I use gconf-editor (which is not installed by default); you can install by doing:

sudo apt-get install gconf-editor

After launching gconf-editor you navigate the tree:

apps > compiz-1 > plugins > unityshell > screen0 > options

There will be a setting in the right hand column 'execute_command' with a value of <Alt>F2 change this to Disabled or set a new combination.

enter image description here

share|improve this answer
That did not work. It was already disabled. I tried to set the shortcut using xbindkeys and after applying the shortcut it works again. But I have to do that everytime I use the compiz --replace. I know it is a good clue but I don't know where to go from there. – Jesse Nov 7 '11 at 15:53
I am not sure... but it sounds like there is some base setting overriding your changes. – cprofitt Nov 9 '11 at 13:56

This is how I managed to do this with Unity

  • Install CompizConfig by execute

    sudo apt-get install compizconfig-settings-manager

  • Open CompizConfig by typing "compiz" into your launcher or ccsm in terminal.

  • Choose Advanced search, enter execute a command into the search box, choose Ubuntu Unity Plugin on the right.

  • Edit the shortcut into something else, like Alt F3 and voila!


share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.