Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

OK. I installed Ubuntu 10.04 a week or so ago over an old Ubuntu partition - no problem. Grub went on fine (it had previously been overwritten by windows).

Then, after remembering how much I like Ubuntu and using a terminal I thought I'd upgrade to 10.10 and increase the size of my Linux partition (the ntfs partition on that drive was barely used).

After doing this I continued the Ubuntu installer... all was fine until near the end when I was told that it had failed to install Grub... I attempted to install it on any of my other partitions and they all failed with the same message (though I'm not convinced they even tried). I then went back to the 10.04 CD and tried that again, same error, grub wouldn't install anymore.

Is this due to grub already being in the MBR or have I broken something when I partitioned?

Partition table is below:

Disk /dev/sda: 320.1 GB, 320072933376 bytes 255 heads, 63 sectors/track, 38913 cylinders Units = cylinders of 16065 * 512 = 8225280 bytes Sector size (logical/physical): 512 bytes / 512 bytes I/O size (minimum/optimal): 512 bytes / 512 bytes Disk identifier: 0xdeb64491

Device Boot Start End Blocks Id System /dev/sda1 1 24352 195599609+ 7 HPFS/NTFS /dev/sda2 24352 38560 114130859+ 83 Linux /dev/sda3 38560 38914 2839553 5 Extended /dev/sda5 38560 38914 2839552 82 Linux swap / Solaris

***Please note that I've since installed grub manually and have Ubuntu setup the way I like it, so I don't want to overwrite the whole install again if it's unnecessary. If I need to test any of these answers is it possible to do without reinstalling the system files?

share|improve this question
Did you resize the partitions via the installer or via some other program? – Casey Keller Oct 16 '10 at 8:02
can you run sudo grub-install /dev/sda (it might be /dev/hda, so run sudo fdisk -l first!!!!) from the live cd and see if it works or gives any errors? – RolandiXor Oct 28 '10 at 17:51

Sounds like you were installing grub to the partition instead of the entire disk. To make sure of this you should run the grub-install command manually:

sudo grub-install /dev/sda

Remembering to replace sda to your disks sd name if you have more than one physical disk.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.