Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I log into my computer, networking is disabled. I always have to enable it so I can connect to the internet. Does anyone know how to set it to enabled by default?

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

From the network-manager applet menu (right click), select edit connections. Edit the connection you wish to automatically connect and select the connect automatically checkbox.

If you wish to start a connection before you log in, select the available to all users checkbox. This is most useful with wireless connections which usually are available only after login.

share|improve this answer
    
Today it worked fine. Looking at the connections, for some reason I have 2 ethernet connections. The one that it was using yesterday didn't have available to all users checked, so it makes sense why it wasn't enabled at log in. The one it used today did, so it was enabled when I logged in. I'm just going to delete the one I used yesterday, because it is redundant. Thanks for the help. –  jumpnett Aug 4 '10 at 14:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.