Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed MDADM for my RAID, and ever since that when I boot up the system just sits at the purple screen forever. After pulling my hair out for a week, I finally discovered - purely by accident - that it's sitting at an initramfs prompt in the background and I have to blindly type "exit" and then Ubuntu resumes normal boot. How do I fix this? I am unable to reboot my machine if I'm not sitting in front of it because it will never boot!

share|improve this question
    
Did you ever come up with a solution to this? I'm having a similar issue. –  slacy Nov 24 '11 at 3:55
    
@slacy I haven't been bothered to investigate it since I almost never have to reboot the file server, but I'm pretty sure the problem is to do with BusyBox, whatever that is. I think it got installed when I installed MDADM. –  Ozzah Nov 24 '11 at 5:38
    
Busybox is utilized in the initramfs that is utilized to start your system up when you don't have access to your hard drives. This can be done for many reasons though. Since you're using a Raid, you might check to see if your raid is running in degraded mode at all, or with fewer drives than its setup for. /proc/mdstat can tell you more perhaps. –  ekthomson May 7 '12 at 18:58

3 Answers 3

up vote 1 down vote accepted

I'm not sure if I have enough information to answer your question, but I do know a way to gather a bit more information.

To hide the logo for the boot and see the actual text of whatever error is causing you to drop to initramfs you will need to catch your computer at the grub boot menu and hit "e" to edit the boot script in use. Find the line that has "ro quiet splash" on it. Remove "quiet" and "splash"

If you get no text at all, there may be some extra text after splash that also needs to be removed. (Or at least, that was the case on my E-350 system.)

You should then see the error message that is causing it to stick in the initramfs prompt.

share|improve this answer

Boot Degraded RAID

  • Modify /etc/initramfs-tools/conf.d/mdadm

    BOOT_DEGRADED=true
    
  • Update initram

    sudo update-initramfs -u
    
  • Reboot

share|improve this answer
    
Since the default is BOOT_DEGRADED=false, it seems the value you want should be BOOT_DEGRADED=true. I tried this and it works, I didn't try yes as well. Sidenote, it seems like a bad default value, the point of RAID is often to be able to keep going even when degraded. –  teeks99 Feb 28 '13 at 0:28
    
how exactly do I do this if im stuck at the initramfs prompt? –  Rob Sep 30 '13 at 19:39

First of all, thanks for your "exit" tip. It saved my hair!

I had a similar problem with Ubuntu 12.10. After tying the command

sudo mdadm --detail /dev/md0

I saw that the raid devices were still being synced. In other words the raid is still considered to be degraded until the devices are in sync. After the sync was finished I didn't have any trouble with the boot.

I hope this helps!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.