Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I couldn't find where I can change Gnome Shell notification settings. I clicked the button that appears with "Don't Show Again" (or something like that) label on a notification, and now when that notification appears, it never disappears until I click on that.

Where is the configuration window of Gnome Shell notifications?

share|improve this question

There is no way to easily configure gnome-shell notifications as of yet. You can disable them or configure them to time out.

dconf-editor allows you to configure some settings

sudo apt-get install dconf-editor

You can also modify notify-send so the messages are transient.

# Move the current script to a backup location
sudo mv /usr/bin/notify-send /usr/bin/notify-send.bak

Now, use gedit for a new wrapper script

gksu gedit /usr/bin/notify-send

copy-paste this into that file

/usr/bin/notify-send --hint int:transient:1 "$@"

Save the script , exit gedit, and make it executable

sudo chmod a+x /usr/bin/notify-send

See also this forums post for addition suggestions.

share|improve this answer
Are you sure your answer will work as intended? /usr/bin/notify-send --hint int:transient:1 "$@" will call /usr/bin/notify-send which contains /usr/bin/notify-send --hint int:transient:1 "$@", you will fall into a recursive script with no end. usr/bin/notify-send should contain /usr/bin/notify-send.bak --hint int:transient:1 "$@", no? – danjjl May 7 '12 at 15:36

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.