Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm running Ubuntu 10.10 with the 2.6.35-22.34-generic kernel and have the latest Vmware player installed, but each time I run Vmware Player it says it needs to load some modules into the running kernel. It does this every time I run Vmware player. It seems to install the modules OK as Vmware player runs after it's apparently installed the modules, but the modules aren't saved as it constantly keeps saying it needs to load modules.

Is there anyway to fix this, other than trying to go for a reinstall?

share|improve this question
add comment

2 Answers

up vote 3 down vote accepted

This might be related to the case of non-compilable VMCI Sock module (due to the changes in the kernel). Please see this link for the solution. Worked fine for me.

I've also had problems running VMWare Player after upgrading Ubuntu from 10.4 to 10.10 as it could not recompile it's modules (due to the changes in kernel) - this guide helped to solve that issue also.

share|improve this answer
    
Thanks I used a similar patch, which worked fine! –  James Oct 16 '10 at 8:06
add comment

You can add the VMware Player modules to be loaded at boot in /etc/modules. This should save the hassle of loading them manually before running VMware Player.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.