Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Wireless option gone

I've got a Broadcom BCM4036 wireless card, as follows:

01:09.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 02)
Subsystem: Linksys Device 0013
Flags: bus master, fast devsel, latency 32, IRQ 5
Memory at fdefc000 (32-bit, non-prefetchable) [size=8K]
Capabilities: [40] Power Management version 2
Kernel modules: ssb

I'm running Ubuntu 11.10.

My wireless card hasn't worked so far (I installed Ubuntu this afternoon), and I've tried various things to make it work (including the answer to this question, and this help page), and it seems that one of them made the wireless option disappear. There's nothing in my additional drivers to enable (other questions mention needing to enable Broadcom STA wireless driver, but I don't see that option).

How do I get it back? More importantly, how do I get my wireless card working?

Do let me know if there's any information you need.

share|improve this question
    
What system are you using? It is possible you have disabled wirless physically (either in the BIOS, by a button, or by accident), though this would not normally cause the system to fail to detect wireless at all. –  RolandiXor Nov 6 '11 at 21:13
    
This is probably the first thing you tried, but if there's a key combination in your pc to activate/deactivate wifi have you tried using it to see if wifi gets activated? I've found that in my system if you use this to turn off wifi the "Enable Wireless" option disappears from the network manager menu. –  devius Nov 6 '11 at 21:15
    
Yeah, install rfkill and check if it's hardware disabled first. If it doesn't show up there you've got a borked driver or module not loading for a couple of possible reasons. –  hbdgaf Nov 7 '11 at 0:03
    
I have the same wireless device, happend to me too. –  Laryllan Nov 7 '11 at 20:42
    
I ended up fixing this by re-installing Ubuntu from CD. I still have an issue where it won't connect to my wireless network, but can at least see it (nm-tool tells me it's Connected (configuring), and eventually re-prompts me for a password, I enter a password I know to be correct, and it retries, then re-prompts, and repeats forever). –  Dominic Rodger Nov 8 '11 at 9:10

1 Answer 1

Clean out your old drivers if any that are lurking around by open a terminal Hit your super key and type Terminal

then

sudo apt-get remove b43-fwcutter firmware-b43-installer
sudo apt-get remove bcmwl-kernel-source

Then type

sudo apt-get update

sudo apt-get install  bcmwl-kernel-source

This should then rebuild your Broadcom drivers for you in your terminal

To save you having to reboot try 'switching on ' your wireless by typing

modprobe wl

alternatively if you want to the B43fwcutter again instead type

sudo apt-get install b43-fwcutter firmware-b43-installer

If you get any errors let us know directly here in the comments. This should be sortable and should be quite easy to do so too. :) but I know it used to frustrate the heck out of me

share|improve this answer
    
thanks for your answer. I tried that, but still get the "Connected (configuring)" problem (see my last comment on the question above). Any ideas? Let me know if there's anything I can run that would help. Really appreciate you taking the time to help me out :) –  Dominic Rodger Nov 20 '11 at 13:39
    
Are you sitting behind a proxy server...ie do you have a direct internet connection or do you need to login via a proxy server? –  andybleaden Nov 22 '11 at 9:19
    
I have a direct internet connection - should I be turning off my wired connection before trying the wireless? –  Dominic Rodger Nov 22 '11 at 11:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.