Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried several formats, but my blender animation render will not have sound. In blender, it plays fine when I press the play button, but there is no sound in the render. Can someone help me with this? Thanks!

In Response to devius: According to the terminal, ffmpeg was not installed. I installed it. Now should it work? It takes a long time to render and I don't want to start it unless I know it's going to work. Update: After installing ffmpeg and restarting, there was still no sound on render. I took the exported file without audio and combined it with the audio track in OpenShot. Good workaround, problem still not fixed. I am marking Explorer' s answer as the answer, even though for me it still doesn't work.

share|improve this question
    
Can someone please help me answer this? I need this project rendered overnight so I can hand it in on monday. –  William Nov 6 '11 at 19:01
    
This is tagged as banshee. Is that intentional? –  michaelms Nov 6 '11 at 19:07
    
Yes. I have tried opening it using banshee, VLC, and Movie Player, all with no avail. –  William Nov 6 '11 at 19:17
1  
What audio output format are you using? AFAIK Blender uses FFMPEG to export video/audio so if ffmpeg can handle the format it should work. You may also try the command "ffmpeg -i [yourfile]" on a terminal to see if there's actually an audio track in there or not. –  devius Nov 6 '11 at 21:19
    
Thanks, I'll try that. –  William Nov 6 '11 at 21:21
add comment

2 Answers 2

up vote 4 down vote accepted

You should have ffmpeg as an output option in Blender.

In terminal, check whether it's installed or not:

~$ ffmpeg
The program 'ffmpeg' is currently not installed.  You can install it by typing:
sudo apt-get install ffmpeg

When you installed it, check if it's included in the format list in blender:

enter image description here

If not, you need to download and reinstall blender. For some reason you have a version that was compiled without ffmpeg support. You could try one of the new 2.49 RC builds.

share|improve this answer
    
Thanks, I installed ffmpeg. I hope this fixes the problem, will render soon! –  William Nov 7 '11 at 1:22
add comment

I had the same problem and the reason was that the audio codec was not enabled.

In the Render tab, choose the MPEG format and you will see a section called Encoding. There you can choose the video codec and the audio codec. For instance, try MPEG-4 and MP3 and you will hopefully get the audio in the output file.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.