Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Works fine with opensource drivers, but with catalyst flickers everytime you press on activities or the lower right bar.

I have 01:00.0 VGA compatible controller: ATI Technologies Inc Mobility Radeon HD 3600 Series

Running fresh ubuntu 11.10 and catalyst 11.10 from ati.com website.

Any suggestions?

EDIT: I want to use the proprietary drivers I know that opensource ones work fine.

share|improve this question
    
    
Not a duplicate the person there has problem with fonts and the panel, mine is flickering ;) –  Marcus Maxwell Nov 6 '11 at 18:50
1  
possible duplicate of ATI graphics card, with gnome shell, screen flickers –  Uri Herrera Jan 17 '12 at 22:35
    
Working perfect with AMD Driver 12.1. :) –  Harshveer Feb 5 '12 at 5:09
    
Duplicate question - [ATI graphics card, with gnome shell, screen flickers][1] (partially solved) [1]: askubuntu.com/questions/78364/… –  JoZ3 Feb 5 '12 at 6:07

4 Answers 4

up vote 1 down vote accepted

This steps worked for me and what you probabably should do is upgrade you ATI drivers. They have solved a lot of those issues you're facing on.

http://www.upubuntu.com/2011/12/how-to-install-amd-catalyst-1112-linux.html

For smooth installation, it is recommended to uninstall currently availabe Catalyst driver. To do this, use these commands from the terminal:

sudo apt-get remove fglrx*

To install the AMD Catalyst 11.12 Linux driver now on Ubuntu 11.10 (32-bit & 64-bit) or any older version, run this sequence of commands:

cd ~/;
mkdir catalyst11.12; 
cd catalyst11.12/

wget -O ati-driver-installer-11-12.run http://www2.ati.com/drivers/linux/ati-driver-installer-11-12-x86.x86_64.run 

If you have a 64 bit system, then install this before anything

sudo apt-get install ia32-libs

After that you can start installing the new ati driver:

chmod +x ati-driver-installer-11-12.run 

sh ./ati-driver-installer-11-12.run

Make now an update for the X.org file with this command:

sudo aticonfig --initial -f

sudo reboot

Hope this helps.

share|improve this answer

Uninstall proprietary drivers.

I did it last week and latest version of open source drivers works perfectly.


sudo apt-get remove --purge xserver-xorg-video-ati xserver-xorg-video-radeon
sudo apt-get install xserver-xorg-video-ati
sudo apt-get install --reinstall libgl1-mesa-glx:i386 libgl1-mesa-glx:amd64 libgl1-mesa-dri:i386 libgl1-mesa-dri:amd64 xserver-xorg-core
sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
sudo rm -rf /etc/ati

share|improve this answer
    
I know that opensource one works, I need proprietary ones. –  Marcus Maxwell Nov 6 '11 at 18:48
    
If the open source driver works, but the proprietary one does not, I highly suggest you file a bug report with ATI. Support for closed source drivers is fairly minimal and does not typically extend beyond installation and configuration. –  bodhi.zazen Apr 2 '12 at 17:35

To solve this (with propietary drivers) install compiz manager, then go to OpenGL and make sure all the options are unchecked. Restart and you are good to go (:

share|improve this answer
1  
As I stated I'm using gnome-shell not Unity. Gnome-shell doesn't use compiz. –  Marcus Maxwell Nov 6 '11 at 20:17
    
oh, that's a problem, sorry I couldn't help you ;D –  victorhqc Nov 26 '11 at 5:40

try to remove Screenlets if you have ones, it helped for me (Ubuntu 11.10, AMD Proprietary Drivers 11.10).

share|improve this answer
    
Don't have any. –  Marcus Maxwell Nov 16 '11 at 13:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.