Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm a long time Ubuntu user, but I haven't been following the community for the last several versions. I just did fresh default minimal amd64 install of Oneiric and I need a 32-bit JRE for a particular application. I last did this on 10.10, so I am not familiar with the multiarch stuff. Instead of installing ia32-libs, I read a bit and tried:

aptitude install default-jre-headless:i386

But that just got me:

The following NEW packages will be installed:
  default-jre-headless{b} openjdk-6-jre-headless{ab} 
The following packages are RECOMMENDED but will NOT be installed:
  icedtea-6-jre-cacao icedtea-6-jre-jamvm 
0 packages upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 27.3 MB of archives. After unpacking 82.1 MB will be used.
The following packages have unmet dependencies:
  default-jre-headless: Depends: java-common which is a virtual package.
  openjdk-6-jre-headless: Depends: openjdk-6-jre-lib (>= 6b23~pre10-0ubuntu5) which is a virtual package.
                      Depends: ca-certificates-java which is a virtual package.
                      Depends: tzdata-java which is a virtual package.
                      Depends: java-common (>= 0.28) which is a virtual package.
                      Depends: libcups2 but it is not going to be installed.
                      Depends: liblcms1 but it is not going to be installed.
                      Depends: libjpeg62 but it is not going to be installed.
                      Depends: libnss3-1d (>= 3.12.9+ckbi-1.82-0ubuntu4) but it is not going to be installed.
                      Depends: libc6 (>= 2.11) but it is not going to be installed.
                      Depends: libfreetype6 (>= 2.2.1) but it is not going to be installed.
                      Depends: libgcc1 (>= 1:4.1.1) but it is not going to be installed.
                      Depends: libstdc++6 (>= 4.1.1) but it is not going to be installed.
                      Depends: zlib1g (>= 1:1.1.4) but it is not going to be installed.
The following actions will resolve these dependencies:

Keep the following packages at their current version:
1)     default-jre-headless [Not Installed]               
2)     openjdk-6-jre-headless [Not Installed]             



Accept this solution? [Y/n/q/?] q

Is aptitude not installing the 32-bit versions of the dependencies? What is the right way to do this? I'll likely want both a 64-bit and a 32-bit JRE if that matters.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

Multiarch support is still in very early stages. In 11.10, there was enough multiarch for flash and skype. In 12.04, it'll cover everything ia32-libs did, but not everything else. That'll take years, although the most popular bits will probably come first.

share|improve this answer
    
Will this answer stay true forever?.. –  ulidtko Aug 1 '13 at 9:28
    
Coverage will probably never be complete, but most of the core libraries are multiarched these days. –  tumbleweed Aug 1 '13 at 10:16
add comment

Answering my own question: I can't find a way to do this, I just went with the 32-bit JRE package from Sun and installed it into /opt.

I had similar problems installing WINE. But that appears to be just about aptitude being broken w.r.t. multiarch, apt-get install WINE worked just fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.