Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 11.10 yesterday in VirtualBox 4.1.4 and every time I boot Ubuntu it says:

/dev/mapper/cryptswap1 is not ready yet or not present

I've done a fair bit of Googling to try to figure out how to fix this but have come up empty. It appears that the swap is not being mounted, I don't see it listed when I type the mount command and look at the list of mounted devices.

How can I fix this?

EDIT:

Apparently it is mounting swap. I just checked dmesg. Perhaps the message is not really an error but a timing thing that corrects itself during the boot?

Adding 1046524k swap on /dev/mapper/cryptswap1.  Priority:-1 extents:1 across:1046524k
share|improve this question
    
i'm getting this on a fresh install of ubuntu 12.10. also, what is weird, it shows me the message on the splash screen with an option to skip or fix manually... but dmesg does not have a single line regarding it! –  gcb Feb 16 '13 at 20:15
add comment

1 Answer 1

Another way to check to see if swap is mounted is with free. To manually correct this problem, do sudo swapon -a, which will tell the system "start swapping on ALL of the pre-configured swap areas"

share|improve this answer
    
Thanks for answering. Apparently swap was being mounted all along. I should have checked dmesg prior to posting but I was fixated on that error message at boot and just didn't check prior to Googling and asking the question on here. –  Frank Hale Nov 7 '11 at 14:53
    
free is easier, if you only have one swap. the last line will show Swap: 0 if you don't have it. or Swap: somenumber if you have it. no need for sudo. –  gcb Feb 16 '13 at 20:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.