Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In Natty Narwhal I used to do some nifty tricks with .gtkrc-2.0 to disable mnemonics (underlined menus) but now it's impossible. I assume in Oneiric Ocelot it will be something different because it uses GTK3.

I used to achieve this by adding the following lines:

gtk-enable-accels = 0
gtk-enable-mnemonics = 0

How can I get rid of the mnemonics in Oneiric Ocelot?

share|improve this question
    
In Natty Narwhal I used this information: ubuntuforums.org/showthread.php?p=7483418 In Oneiric Ocelot this doesn't work. –  Kristiyan Nov 6 '11 at 19:28
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  jrg Feb 3 '12 at 1:26
    
@jrg I contest this one. It's a cogent question, all requests for further information have been answered. –  Jacob Johan Edwards Feb 3 '12 at 20:58
    
@JacobJohanEdwards user hasn't been seen since mid-nov. I'd define that as abandoned, its almost two months, and it has no answer. –  jrg Feb 3 '12 at 21:00
    
@jrg The status of the original user doesn't matter. It's a real question that doesn't fit any of the close vote categories, and could be upvote-answered by the community. –  Jacob Johan Edwards Feb 3 '12 at 21:03
show 1 more comment

3 Answers

GTK3 doesn't use gtkrc anymore, but moved to styling with CSS. But there still is a way to change global settings. Quoting from the GTK reference:

GTK+ reads default values for settings from settings.ini files in /etc/gtk-3.0 and $XDG_CONFIG_HOME/gtk-3.0.

See that page for some more details.

I wonder if this works in Unity though, with the global menu. I don't know if these settings are adapted by it.

share|improve this answer
add comment

After so long time and no answer found on my question I found it!

To hide mnemonics (keyboard accelerators) in GTK 3.x you just need to open:

/usr/share/themes/THEME_NAME/gtk-3.0/settings.ini

Add the following line:

gtk-enable-mnemonics = 0

And save the file. Log out or change your theme with another one then change it back. That's all. Nothing hard to do, only little research.

PS: Of course after update of ubuntu-light-themes package this will be lost and need to be redone again.

share|improve this answer
add comment

add

gtk-auto-mnemonics = 1

in your theme settings: /usr/share/themes/YOUR_THEME_NAME/gtk-3.0/settings.ini

share|improve this answer
    
Editing an installed theme from /usr/share/themes is a BAD idea - as changes will be overwritten when new package is installed –  Vadim Rutkovsky Feb 7 '12 at 4:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.