Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

i have dell inspiron N4010 laptop with broadcomm 4313 wifi chip,and the driver for wifi is installed and i am able to switch on wifi,but it does not detect access points,even ad-hoc networks created to test.I dual booting Ubuntu with windows and i had the same problem with 10.10 before,but a restart with wifi switched has solved the problem but not know.I am including the output of the following commands.

saikiran@saikiran-Inspiron-N4010:~$ sudo lshw -class network
  *-network               
       description: Wireless interface
       product: BCM4313 802.11b/g/n Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: wlan0
       version: 01
       serial: 70:f1:a1:8b:7a:38
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=brcmsmac driverversion=3.0.0-12-generic firmware=N/A latency=0 link=no multicast=yes wireless=IEEE 802.11bgn
       resources: irq:17 memory:f0300000-f0303fff
  *-network
       description: Ethernet interface
       product: AR8152 v1.1 Fast Ethernet
       vendor: Atheros Communications
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: eth0
       version: c1
       serial: b8:ac:6f:5a:6f:a6
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI firmware=N/A latency=0 link=no multicast=yes port=twisted pair
       resources: irq:45 memory:f0200000-f023ffff ioport:3000(size=128)

saikiran@saikiran-Inspiron-N4010:~$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=19 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

ppp0      no wireless extensions.

saikiran@saikiran-Inspiron-N4010:~$ rfkill list
0: dell-wifi: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: dell-bluetooth: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
3: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

saikiran@saikiran-Inspiron-N4010:~$ sudo iwlist scan
[sudo] password for saikiran: 
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

wlan0     No scan results

ppp0      Interface doesn't support scanning.

does ubuntu scan for networks at the time of boot?

UPDATE:I reinstalled the OS,while trying liveCD wifi is working and detecting AP(access points) without installing properiteries drivers.after installing the same problem recurred.

UPDATE:I reinstalled the OS and driver and also installed ia32-libs,suddenly wifi detects access points,but some what erratic and have to restart with wifi off whenever it does not detect.Sometimes when you switch off and on wifi,it is saying device not ready and i have to restart to make it work.Can anyone explain the debacle.

share|improve this question
    
A suggestion: After the fresh install when it asks for activating proprietary STA driver... DONT install it... I had similar problem several times.. –  abhishek Jan 20 '12 at 20:26
add comment

3 Answers

You should use Network Manager to connect to wireless network. It periodically scans air for the wireless networks. Check if your notebook has some hardware buttons to switch Wi-Fi on/off.

Or you can connect to Internet with LAN cable and install WiCd.

share|improve this answer
    
@PocketSam.ya,i am using network manager and the wifi can be swithched on and off,the problem is it does not scan/detect any AP –  saiki4116 Nov 6 '11 at 17:30
add comment

if you have access to a wired network ..then try this solution..

http://www.computerandyou.net/2011/10/how-to-solve-no-wireless-network-detected-in-ubuntu-11-10/

share|improve this answer
    
,unfortunately i reinstalled os,but still the driver is installed.i had to update the cache for installing synaptic on a very slow mobile gprs network.I will try your solution and hope it works –  saiki4116 Nov 6 '11 at 22:05
add comment

try disabling the hardware driver. Strangely when I was installing 11.10 on the same hardware it showed networks at the time of install. Later, when the OS booted and the broadcom driver was active I could not see any networks. Disabled the hardware driver and voila. It's just some retarded bug I guess.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.