Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Even my main monitor is shown as unknown. I have tried setting up dual monitors using Nvidia settings with no joy however it does recognize that I have 2 monitors.

This was not an issue in 11.04. My problem with the Nvidia settings appears to be that my 2 monitors require different resolutions but even when I set them to a resolution that they both can handle, it is then only appearing in cloned mode. I really hope someone can help or I will have to roll back to 11.04.

Why won't Ubuntu 11.10 recognize that I have 2 Monitors?

Here is the contents of my xorg.conf:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 280.13  (buildd@rothera)  Thu Aug 11 17:28:49 UTC 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: xconfig, VertRefresh source: xconfig
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-0"
    HorizSync       30.0 - 83.0
    VertRefresh     50.0 - 76.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 7025 / nForce 630a"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "CRT: 1280x1024 +1024+0, DFP: 1024x768 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection"

ok I have tried disper -e. Problem is that Nvidia settings appear to be treating both monitors as the same one. so changing the settings to one has no effect, but change the other and it affects both screens identically.

Results of disper -l as follows:

    carter@carter-desktop:~$ disper -l
display DFP-0: HP vs17
 resolutions: 320x240, 400x300, 416x312, 512x384, 576x432, 680x384, 640x480, 720x450, 640x512, 800x512, 840x525, 800x600, 960x540, 832x624, 960x600, 896x672, 1024x768, 1152x864, 1280x960, 1280x1024
display CRT-0: CRT-0
 resolutions: 320x240, 400x300, 416x312, 512x384, 576x432, 680x384, 640x480, 720x450, 640x512, 800x512, 840x525, 800x600, 960x540, 832x624, 960x600, 896x672, 1024x768, 1152x864, 1360x768, 1280x960, 1440x900, 1280x1024, 1400x1050, 1600x1024, 1680x1050, 1600x1200, 1920x1080, 1920x1200, 1792x1344
carter@carter-desktop:~$ 
share|improve this question
    
Please try disper -e to extend your desktop to a second screen and then enter the nvidia-settings, do the proper configuration and save the X-org. –  cuichi Nov 6 '11 at 12:59
add comment

4 Answers

up vote 6 down vote accepted

I solved this problem a few minutes ago on my system. For me it worked in the following way:

  1. Installed the post-release nvidia-driver. enter image description here
  2. Start the nvidia-settings to configure my dual-screen, there you have to use the TwinView (not the seperate X-Config) and don't forget to choose a primary monitor. The problem I encountered during the config was, that I it only seems to work if I choose the left monitor as primary. To Test you can use the Apply-Button. enter image description here If everything works you can save to X Configuration File.

Here my resulting xorg.conf if you want to read it:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 280.13  (buildd@rothera)  Thu Aug 11 17:28:49 UTC 2011

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0" EndSection

Section "Files" EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5" EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd" EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Samsung SMS22A350H"
    HorizSync       30.0 - 81.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS" EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTS 450" EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "TwinViewXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "CRT: nvidia-auto-select +1920+0, DFP: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection EndSection
share|improve this answer
    
Thanks for the reply but when I try that all I get is clone mode which is no good to me. –  Chris Carter Nov 6 '11 at 13:54
    
Have you selected the twinview? –  tvn Jun 4 '13 at 12:44
add comment

When I solved the problem using Xinerama messed everything for me.

What I did was delete my xorg.conf file (after backing it up of course).

I then ran nvidia-xconfig and ran nvidia-settings. Got my second monitor recognized and used twinview, and then saved to my xconfig file.

Heres what my xorg.conf looks like:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    #VertRefresh     50.0 - 76.0
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics W1952"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 460"
EndSection

Section "Screen"

# Removed Option "metamodes" "DFP: nvidia-auto-select +0+0, CRT: nvidia-auto-select +1600+0"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "metamodes" "CRT: nvidia-auto-select +1600+0, DFP: nvidia-auto-select +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

I was getting an error for a while that X couldn't find a suit

share|improve this answer
add comment

I did just like tvn said, but I ran

apt-get upgrade 
sudo nvidia-xconfig 

then rebooted before setting anything up in nvidia-settings.

share|improve this answer
add comment

Xubuntu 12.04, GEforce GTX650, 2 x 24 inch 1920 x 1200 screens connected by DVI-D both run in portrait mode.

None of the Ubuntu Software Center nvidia drivers would rotate screens. The current driver is ver 304.88.

Downloaded: NVIDIA-Linux-x86_64-319.23.run from: http://www.nvidia.com/Download/index.aspx?lang=en-us

then: Ctrl-Alt-F1 - full screen terminal mode

sudo service lightdm stop
cd Downloads
sudo ./NVIDIA-Linux-x86_64-319.23.run

After installation:

sudo reboot

logon and open a terminal window (Windows - T)

sudo nvidia-settings

Or the same program from the menu: Settings / NVIDIA X Server Settings

The latest nvidia drivers include screen rotation in the X Server Display Configuration screen. The ubuntu Settings / Settings Manager / Display will still not run, but is not needed.

Enable Xinerama - all working sweetly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.