Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As Ubuntu's TeXLive is quite old (version 2009), I always hear TeX people recommending installing the latest TeXLive directly from CTAN. (Yes, I need the same package mentioned in that question.) I did this, and installed TeXLive 2011.

Now some packages I need to install (e.g. gummi) depend on Ubuntu's TeXLive packages. How can I prevent Ubuntu's TeXLive packages from being installed since I already have a manually installed TeXLive?

share|improve this question

4 Answers 4

Create a dummy package which doesn't provide any file but declares that it provides the package names from texlive. There's a tool for that: equivs-build from the equivs package.

equivs-build takes a file that declares package dependencies (such as Provides: foo, bar meaning that installing the package is as good as installing the packages foo and bar), and builds a .deb binary package. You can use equivs-control to generate a template. TUG provides equivs files for TeXlive 2011 and TeXlive 2013. I'll reproduce their 2013 file here:

Section: misc
Priority: optional
Standards-Version: 3.9.4

Package: texlive-local
Version: 2013-1
Maintainer: you <you@yourdomain.example.org>
Provides: chktex, biblatex, biblatex-dw, cm-super, cm-super-minimal, context, 
 dvidvi, dvipng, feynmf, fragmaster, jadetex, lacheck, latex-beamer, 
 latex-cjk-all, latex-cjk-chinese, latex-cjk-chinese-arphic-bkai00mp, 
 latex-cjk-chinese-arphic-bsmi00lp, latex-cjk-chinese-arphic-gbsn00lp, 
 latex-cjk-chinese-arphic-gkai00mp, latex-cjk-common, latex-cjk-japanese, 
 latex-cjk-japanese-wadalab, latex-cjk-korean, latex-cjk-thai, latexdiff, 
 latexmk, latex-sanskrit, latex-xcolor, lcdf-typetools, lmodern, luatex, 
 musixtex, passivetex, pgf, preview-latex-style, prosper, ps2eps, psutils, 
 purifyeps, t1utils, tex4ht, tex4ht-common, tex-gyre, texlive, texlive-base, 
 texlive-bibtex-extra, texlive-binaries, texlive-common, texlive-extra-utils,
 texlive-fonts-extra, texlive-fonts-extra-doc, texlive-fonts-recommended,
 texlive-fonts-recommended-doc, texlive-font-utils, texlive-formats-extra,
 texlive-games, texlive-generic-extra, texlive-generic-recommended,
 texlive-humanities, texlive-humanities-doc, texlive-lang-african,
 texlive-lang-all, texlive-lang-arabic, texlive-lang-cjk, texlive-lang-cyrillic,
 texlive-lang-czechslovak, texlive-lang-english, texlive-lang-european,
 texlive-lang-french, texlive-lang-german, texlive-lang-greek, 
 texlive-lang-indic, texlive-lang-italian, texlive-lang-other, 
 texlive-lang-polish, texlive-lang-portuguese, texlive-lang-spanish,
 texlive-latex-base, texlive-latex-base-doc, texlive-latex-extra, 
 texlive-latex-extra-doc, texlive-latex-recommended, 
 texlive-latex-recommended-doc, texlive-luatex, texlive-math-extra, 
 texlive-metapost, texlive-metapost-doc, texlive-music,
 texlive-omega, texlive-pictures, texlive-pictures-doc, texlive-plain-extra,
 texlive-pstricks, texlive-pstricks-doc, texlive-publishers,
 texlive-publishers-doc, texlive-science, texlive-science-doc, texlive-xetex,
 thailatex, tipa, tipa-doc, xindy, xindy-rules, xmltex 
Architecture: all
Description: My local installation of TeX Live 2013.
 A full "vanilla" TeX Live 2013
 http://tug.org/texlive/debian#vanilla

You may want to put your email address on the Maintainer line (so that you remember where this package is coming from) and tweak the list of provided packages if you didn't install a full TeXlive. Assuming you've used debian-equivs-2013-ex.txt as above (if not, you may need to tweak the file names), run the following commands:

equivs-build debian-equivs-2013-ex.txt
sudo dpkg -i texlive-local_2013-1_all.deb
share|improve this answer

PocketSam is correct, you cannot make apt do this; you need to mess around with dpkg directly.

You will need to manually download the gummi .deb file:

apt-get download gummi

Then, manually install the dependencies from gummi using apt-get, except for TeXLive.

Finally, you can use dpkg --ignore-depends to install gummi.

Beware that this is error-prone, and if you attempt to do an apt-get upgrade of gummi, it will probably pull in the old TeXLive.

share|improve this answer

There is a package, gummi-notex, that does exactly that. See here for installation instructions of the ppa (currently available up to the saucy (13.10) ubuntu version)

share|improve this answer

dpkg can ignore any conflicts and dependencyes.

dpkg -i --ignore-depends=package1,package2 targetpackage.deb

But I cant see solution for apt-get for now.

share|improve this answer
    
From reading the man page, it seems to me that this option will only ignore packages that cannot be downloaded for some reason. So it will still install texlive unless I unplug the network cable (or even then if some texlive packages happen to have already been downloaded but not installed). –  Szabolcs Nov 6 '11 at 17:29
    
You're right. I'll update my answer. –  PocketSam Nov 8 '11 at 3:56
    
That's a bad idea: it'll work now, but APT will choke later on dependency resolution when you install some related package or upgrade your system. –  Gilles May 12 at 21:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.