Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've setup Ubuntu via Wubi recently for a friend and he came back with a complaint: On reboots the Windows partition is always selected by default, figured this was just a need to update Grub but realized that Wubi writes to the Windows Boot Manager and does not use Grub.

Though this is technically a "Windows" question I wasn't able to find a clear answer for this.

How to do I modify the boot/selection order for Operating systems (Mainly Ubuntu via Wubi) on the Windows Boot Manager?

share|improve this question
    
What version of Windows is it? –  mac9416 Aug 4 '10 at 2:01
    
This case it's Windows Vista –  Marco Ceppi Aug 4 '10 at 12:09
add comment

2 Answers

up vote 5 down vote accepted

The Wubi Guide on the Ubuntu wiki (manual uninstall section) gives some hints on how to edit the Windows Boot Manager boot order in Vista and XP.

In Windows Vista you can either use EasyBCD or modify the boot menu via Control Panel (Classic View) > System > Advanced system settings; then choose "Settings..." under Startup and Recovery.

In Windows XP, edit C:\boot.ini.

According to this Wubi HowTo, the default OS can be changed in Windows 7 by going to Control Panel > Advanced System Settings, and in the Default operating system drop-down selecting Ubuntu instead of Windows.

share|improve this answer
    
I'll gives these options a go - but this looks like what I'll need. Thanks! –  Marco Ceppi Aug 4 '10 at 12:10
    
Just some clarification in Vista it's Control Panel (Classic View) > System > Advanced system settings Then choose "Settings..." under Startup and Recovery I wasn't able to test XP or Windows 7 but I'm accepting this answer as it did work well. Thanks! –  Marco Ceppi Aug 5 '10 at 2:57
    
Thanks for the correction; I updated the answer. Hopefully if someone else tries other Windows versions they'll comment whether it worked or not. I'm glad it worked for you on Vista! –  mac9416 Aug 5 '10 at 16:25
    
You don't need to edit C:\boot.ini in XP. The same instuctions work on all versions of windows i.e. go to Startup & Recovery settings. WARNING: setting Ubuntu as the default and also the timeout below 10 can result in Windows not being able to boot. –  bcbc Nov 4 '11 at 16:16
add comment

Click start and run msconfig(in Windows). Look for the Boot tab and change the order of the OS. I can't remember what it looks like its been a while, but its pretty self explanatory.

Good Luck and happy Ubuntuing!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.