Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I normally use 4 different workspaces for different things, and they are always the same, can I make a different background image for each one of them?

I would like an answer that works for both Unity and the Classic desktop.


This question has multiple answers covering different ubuntu versions:

share|improve this question

6 Answers 6

Ubuntu 10.04

You can get the Wallpaper plugin for Compiz by installing compiz-fusion-plugins-extra (sudo apt-get install compiz-fusion-plugins-extra). It will show up under the Utility category in CompizConfig Settings Manager.

Before you can use it, you'll have to configure Nautilus to not draw the desktop. Run gconf-editor and uncheck the setting /apps/nautilus/preferences/show_desktop. This will make all of your desktop icons disappear, and there is no solution to this drawback at this time.

To configure the Wallpaper plugin, add images to the list of backgrounds. They will be assigned to workspaces in the order they are listed, and you don't have to have the exact right number:

CompizConfig

The result:

Expo

share|improve this answer
    
This is great! I don't use desktop icons to begin with - so this is quite a sufficient solution! –  Marco Ceppi Sep 21 '10 at 14:10
4  
Sucks we can't keep the desktop icons (brainstorm.ubuntu.com/idea/93) –  Olivier Lalonde Sep 22 '10 at 15:50
1  
I once had working patches to make nautilus draw a transparent desktop when in a compositing environment so we could get desktop icons and wallpaper specific icons. Unfortunately they were never accepted and modern nautilus needs more changes I haven't dug in to to get the same job done. –  Travis Watkins Dec 9 '10 at 3:10
2  
I don't see the setting in 12.04. –  Colin Harrington May 10 '12 at 21:31
2  
For 12.04 read this: askubuntu.com/questions/116741/… –  HDave Aug 13 '12 at 18:06

12.04

enter image description here

how-to

Launch dconf-editor (install dconf-tools Install dconf-tools if required)

enter image description here

Navigate to org - gnome - desktop - background

Now the very strange bit - by default the show-desktop-icons is unticked. Click it to tick it and click it again to untick it.

Now install some extra software:

compizconfig-settings-manager Install compizconfig-settings-manager

compiz-fusion-plugins-extra Install compiz-fusion-plugins-extra

Launch the Dash and search for ccsm

Filter to wallpaper - enable the wallpaper plugin and add New wallpaper as shown.

enter image description here

Notes:

  • during testing, when I enabled wallpaper the desktop froze solid. I had no choice but to do a hard-reset via the power button.
  • remember this important bit of information:
    • Log out and back in again to show new wallpapers

What are some of the issues with ccsm and why would I want to avoid it?


If you prefer not to risk ccsm then you can use gconf-editor

gconf-editor Install gconf-editor

enter image description here

Add the two plugins as shown.

enter image description here

Add a comma-separated list with the full-paths to your wallpaper as shown.

share|improve this answer
3  
"During testing, when I enabled wallpaper the desktop froze solid. I had no choice but to do a hard-reset via the power button" ... which perfectly illustrates the issues with using ccsm! –  Ryan McClure Jul 3 '12 at 20:50
    
For me, this only works with the wallpapers provided in /usr/share/wallpapers. Doesn't work with wallpapers off the web, just shows black screen. Any idea on how to fix? –  Stuart Jun 12 '13 at 14:56
    
The wallpapers have to be on a permanantly mounted drive, so that the wallpaper plugin can fetch it as soon as the user logs in. Refer to Ubuntu Wiki's Automatically Mount Partitions page –  HEXcube Mar 5 at 18:31

11.10

In next window, navigate to “apps/nautilus/appearances” and un-check “show_dekstop” in right. enter image description here

  • Open Compiz and search Wallpaper plugin enter image description here

  • Click “New” to choose a wallpaper for your first workspace.

enter image description here

  • Browse to select an image. enter image description here

Repeat this step for all your workspaces. Once done, enable the wallpaper plugin.


For those who don't have "show_desktop" in Configuration Editor-

  1. Install gnome-tweak-tool, enter in terminal-
    sudo apt-get install gnome-tweak-tool
  2. Key Alt+F2 and enter gnome-tweak-tool and hit enter.
  3. Click on ▸ Desktop ▸ Have file manager handle the desktop ▸ switch to Off

picture of gnome-tweak-tool dialog box

4.Proceed with the above instructions for changing compiz settings.

share|improve this answer
    
It seems this approach makes Docky not work, and one can't see files and folders on the Desktop. (I'm using Gnome-Classic on 12.04). Is there an option and solution to having this feature without losing Desktop functionality, or accessories like Docky? –  Dave M G Jul 4 '12 at 14:24

Ubuntu 13.04, 13.10 and 14.04

enter image description here

How to

Launch dconf-editor (install dconf-tools Install dconf-tools if required)

enter image description here

Navigate to org - gnome - desktop - background

Now the very strange bit - by default the show-desktop-icons is unticked. Click it to tick it and click it again to untick it.

Now install some extra software: compizconfig-settings-manager Install compizconfig-settings-manager

Ensure you have the following package installed: compiz-plugins Install compiz-plugins

Launch the Dash and search for ccsm

Filter to wallpaper - enable the wallpaper plugin and add New wallpaper as shown.

enter image description here

What are some of the issues with CCSM and why would I want to avoid it?

Finally - enable the use of workspaces in your System Settings (Cog Wheel menu option)

pic


If you prefer not to risk ccsm then you can use dconf-editor as installed above.

pic

Add the two plugins as shown.

enter image description here

Add a comma-separated list with the full-paths to your wallpaper as shown.

Then enable your workspaces as per above.

share|improve this answer

Ubuntu 12.10

This is not currently possible. Due to bug #1020830, the necessary Compiz plugin is not available.

share|improve this answer
    
This bug has been fixed acording to launchpad This bug was fixed in the package compiz - 1:0.9.9~daily13.01.14-0ubuntu1. Is it possible now? –  Alvar Jun 1 '13 at 23:19

Ubuntu 11.04

I know this is possible with compiz. Do you have/use compiz? if so (install and) open compizconfig-settings-manager and look under the wallpaper plugin.

If I recall, adding multiple wallpapers would set them in order (ie. the first image selected goes to workspace one, the second image goes to workspace two). You might need to muck about in the settings to get compiz to render your wallpaper.

Open the Terminal and type this command:

 sudo apt-get install compiz compiz-core compizconfig-settings-manager compiz-plugins

Then navigate to :

  • system -> preferences -> compizconfig in settings manager.

Type "wallpaper" in the search, click the wallpaper plugin, enable it on the left, select your wall papers.

I believe you may need to change more settings in the gnome compatibility options or something like that, but I can't recall exactly.

share|improve this answer
    
Please list the commands necessary and list all the software that I need if I have a fresh install of 11.04. –  Alvar Nov 6 '11 at 9:18
    
always assume that I don't have extra software installed. –  Alvar Nov 6 '11 at 9:18
    
right, sorry. Uh, fresh from 11.04? sudo apt-get install compiz compiz-core compizconfig-settings-manager compiz-plugins should do it for installation, then navigate to system -> preferences -> compizconfig settings manager. type "wallpaper" in the search, click the wallpaper plugin, enable it on the left, select your wall papers. I believe you may need to change more settings up in the gnome compatibility options or something, i don't recall exactly and don't have anything i can test it on –  thefinn93 Nov 6 '11 at 9:23
3  
add it in your answer and improve the horrible formatting. –  Alvar Dec 3 '11 at 12:28

protected by gertvdijk Oct 16 '13 at 13:46

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.